Go Back   The 75 and ZT Owners Club Forums > Search Forums
Register FAQ Image Gallery Members List Calendar Search Today's Posts Mark Forums Read
Notices

Showing results 1 to 31 of 31
Search took 0.01 seconds.
Search: Posts Made By: mgj11
Forum: Technical Help Forum 3rd May 2022, 13:54
Replies: 0
Views: 235
Posted By mgj11
Unhappy Sub frame wows

I'm having clutch problems (again):mad:. Last time I replaced the clutch and slave without removing the sub frame.
This time I wanted to remove it and give it a bit of a refurb and it very tight to...
Forum: Technical Help Forum 29th January 2022, 17:48
Replies: 4
Views: 502
Posted By mgj11
Powerfold mirrors auto mode?

Hi
Has anyone got thier powerfold mirrors to close and open when the turn the ignition on and off.
Tried a box off ebay but can't seem to get it to work. :duh:
Forum: Technical Help Forum 23rd November 2021, 09:07
Replies: 9
Views: 642
Posted By mgj11
Thanks. I'll buy some stronger rubbers, any...

Thanks. I'll buy some stronger rubbers, any recommendations?
Forum: Technical Help Forum 23rd November 2021, 08:25
Replies: 9
Views: 642
Posted By mgj11
New Exhaust issues

I have just replaced my silencer with a new clamshell one from DMGRS. its much larger than the cheap one on the car when I got it. I brought the correct clamp but it seems to rattle around, and makes...
Forum: Technical Help Forum 6th June 2021, 09:43
Replies: 5
Views: 348
Posted By mgj11
Thanks for the reply looks like four wires going...

Thanks for the reply looks like four wires going into the motor so itís probably an older fan from the parts bin or replacement.
Forum: Technical Help Forum 6th June 2021, 09:04
Replies: 5
Views: 348
Posted By mgj11
Resistor for fan

I have been trying to recommission my air-conditioning there are no leaks and itís fully gassed but itís still not getting cold. I then thought about the fan Itís not kicking in at low speed I...
Forum: Technical Help Forum 27th January 2021, 11:42
Replies: 4
Views: 476
Posted By mgj11
Thanks what I thought, but just wondered if they...

Thanks what I thought, but just wondered if they can out of the factory like that or was there a way that MG Rover fixed them on.
Forum: Technical Help Forum 26th January 2021, 09:30
Replies: 4
Views: 476
Posted By mgj11
How to fix the gear knob wobble

When I purchase my ZT the previous owner had wedged a 75 gear knob on. I found an original ZT one which fits OK, but it still has a little wobble and quite easy to pull off.
Is there some way of...
Forum: Technical Help Forum 14th January 2021, 12:20
Replies: 4
Views: 592
Posted By mgj11
EWS replacement

Dear All


A question about keys. My car only came with 1 key and I'm wondering if I purchased (cheaper than new key) one of the used "ECU kits" which comes with ECU, EWS, RF receiver and...
Forum: Technical Help Forum 5th January 2021, 10:49
Replies: 8
Views: 885
Posted By mgj11
Talking inexperience and ignorance I think and luck...

inexperience and ignorance I think and luck :icon_lol:

I was looking too wire in an auto dimming mirror and rain sensor and saw the mess.
Forum: Technical Help Forum 21st December 2020, 09:55
Replies: 8
Views: 885
Posted By mgj11
Sorted (hopefully)

I think I've sorted it, looked for errors using TOAf and got this.

87- K bus
Error count 252
Short circuit to ground
Sporadic error

C7 lever-type 1 sensor
Errors counts 0
short circuit to...
Forum: Technical Help Forum 14th December 2020, 09:23
Replies: 8
Views: 885
Posted By mgj11
Thanks Simon, yes I did, but one of the issues is...

Thanks Simon, yes I did, but one of the issues is access, I can't get enough access by just removing the bottom kick plate and am wonder what else I could remove to get better access.
Forum: Technical Help Forum 14th December 2020, 08:14
Replies: 8
Views: 885
Posted By mgj11
K-Bus ?

I'm still having intermittent issues, which I believe are down to the K-Bus (plenum is clear and can't find any other water ingress). The tell tail indicator light works intermittently as do the...
Forum: Technical Help Forum 17th November 2020, 14:33
Replies: 1
Views: 331
Posted By mgj11
More indicator wows

I have been have issue with the indicators, but they are now currently working but the indicator lights on the dash aren't, they will work intermittently. Any ideas would be gratefully received.:(
Forum: Technical Help Forum 16th November 2020, 13:39
Replies: 4
Views: 520
Posted By mgj11
I've changed the clock spring/squib and both...

I've changed the clock spring/squib and both indictor and wiper stalks, cleaned all contacts. The volume control and cruise control are working but I still have an intermittent problem will the...
Forum: Technical Help Forum 11th November 2020, 17:58
Replies: 4
Views: 520
Posted By mgj11
Thanks, are there different type or is it the...

Thanks, are there different type or is it the same for all Rover 75 and MG ZT?
Forum: Technical Help Forum 11th November 2020, 08:15
Replies: 4
Views: 520
Posted By mgj11
Steering column controls issues

I had problems this morning with all the controls on the steering column, the indicators didn't work, the wipers didn't work, the radio controls and cruise set also didn't work.
After about 1/2 hour...
Forum: Technical Help Forum 10th November 2020, 09:02
Replies: 1
Views: 334
Posted By mgj11
Indicator issues

Dear All

I have been having issues with the indicators on my v6. They work fine when I start off then after about half an hour driving they stop working, but will start work again after about...
Forum: Technical Help Forum 2nd October 2020, 09:07
Replies: 6
Views: 444
Posted By mgj11
Thanks for all the replies , I have ordered a...

Thanks for all the replies , I have ordered a replacement and will have a go at replacing it
Forum: Technical Help Forum 1st October 2020, 09:37
Replies: 6
Views: 444
Posted By mgj11
Window issues

This morning I had an issue with my passenger side window. It goes down smoothly but when I went to put it up it just jerked then stopped, I could get it back up by doing, up then off repeatedly (it...
Forum: Technical Help Forum 6th September 2020, 14:38
Replies: 3
Views: 483
Posted By mgj11
Thanks, I've got the wiring (from a disco 3) and...

Thanks, I've got the wiring (from a disco 3) and have connected a rear dimming mirror from a disco 3 the works fine.
Might give it a go and see what happens, if not BMW option looks good, thanks
Forum: Technical Help Forum 4th September 2020, 18:57
Replies: 3
Views: 483
Posted By mgj11
Rain sensor

Just wondering if the rain sensor from a land Rover discovery 3 will work in an MG ZT
Forum: Technical Help Forum 26th August 2020, 09:52
Replies: 1
Views: 304
Posted By mgj11
Powerful mirror wiring

I'm attempting to fit powerfolds to my ZT, I have the mirrors and switch but no loom.
I understand the extra wiring is quite easy but a b**ger to fit, but I wondering where I can get/make the...
Forum: The 75 and ZT Owners Club General Forum 16th July 2020, 17:14
Replies: 14
Views: 2,025
Posted By mgj11
finally got it sorted, it was a pesky brakes...

finally got it sorted, it was a pesky brakes switch, one of the lungs had broken on the holder and it fallen out. Replace and now works
Forum: Technical Help Forum 1st May 2020, 14:59
Replies: 4
Views: 644
Posted By mgj11
I think it will be a trip to T4 after shutdown....

I think it will be a trip to T4 after shutdown. Thanks
Forum: Technical Help Forum 1st May 2020, 11:34
Replies: 4
Views: 644
Posted By mgj11
Air bag light

I have the dreaded/common problem of the air bag fault. The light will come on the message centre but not on the light just below.
I have changed the plugs in the seats but the problem persists. I...
Forum: The 75 and ZT Owners Club General Forum 30th April 2020, 14:26
Replies: 14
Views: 2,025
Posted By mgj11
Have already tried that thanks

Have already tried that thanks
Forum: The 75 and ZT Owners Club General Forum 28th April 2020, 20:10
Replies: 14
Views: 2,025
Posted By mgj11
Thanks Trikey

Thanks Trikey
Forum: The 75 and ZT Owners Club General Forum 28th April 2020, 20:10
Replies: 14
Views: 2,025
Posted By mgj11
Have fitted Vacuum pump and actuator

Have fitted Vacuum pump and actuator
Forum: The 75 and ZT Owners Club General Forum 28th April 2020, 19:18
Replies: 14
Views: 2,025
Posted By mgj11
Unhappy Retro fit v6 cruise control frustration

Dear All
I've just fitted cruises control on my 190+ v6. The master switch lights up but the cruise will not engage when the steering wheel controls are used. I have changed the brake pedal switch...
Forum: The 75 and ZT Owners Club General Forum 31st January 2020, 11:21
Replies: 6
Views: 981
Posted By mgj11
Heater work for 30 minutes then goes cold

Hi wondering if anyone has had this problem and found out why. I set the heat to say 24C it get hot then after about 30 minutes blows cold air, this happens on all settings Aircon, Econ, man and...
Showing results 1 to 31 of 31

 
Forum Jump

All times are GMT +1. The time now is 14:35.


Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2022, Jelsoft Enterprises Ltd.
Copyright © 2006-2022, The Rover 75 & MG ZT Owners Club Ltd