View Single Post
Old 16th June 2014, 13:21   #1
Regular poster
Peugeot 604/Jag X350

Join Date: Feb 2013
Location: Ruislip
Posts: 85
Thanks: 1
Thanked 28 Times in 16 Posts
Default Diagnostics Tool Demo Day result and feedback

As requested, here is the results of the demo day as I remember it. It was a bit hectic...

If you were there and can confirm what I say then that would be great. If your memory is different to mine, well I suppose people should hear that too...

AM at Barnet Retail Park:-
Freelander 1 TD4: engine ECU worked in EDC15C4 mode. Other ECUs not working.
Elise S1: working in MEMS1.9 mode. Only ECU on the car.
Elise S2: not working (never expected it to). Lotus changed the MEMS3 too much for my tool.
MGF: worked 100% (engine, airbag, ABS).
MGTF: worked 100% (engine, airbag, ABS).
MGTF LE500: worked 100% (engine, airbag, ABS) but could not reset service indicator.
Freelander 1 petrol worked on MEMS1.9. Didn't try anything else as this was just a random shopper asking for directions.
MG ZR diesel: worked 100% (engine, airbag, ABS). This was a real result for me as the owner had been to multiple garages and no-one could read the codes, but my tool could. He then spammed Facebook to tell everyone which is exactly what I need.

PM at Halfway House:-
Various Rover 75/ZT tried, maybe 5 or 6?
Airbag ECUs 100% success rate. Several airbag warning lights sorted. It can be a bit slow to login though (this will be fixed I promise).
ABS ECUs 100% success rate. None had any faults. Live data also worked.
MEMS3 on 1.8 turbo 100% success rate. This is in Rover mode not EOBD mode. All three of them had P1520 (I think it was) on. 100% still had P1520 after all the other codes cleared. MEMS3 also often seems to need the ignition turned off for a few seconds and then turned on before it will connect. I found the same issue on a Rover 45 (a mate's one not demo day); I think it's an immo thing or something.
100% success rate on diesels in EDC15C2 mode. I have previously tested W reg right through to a facelift 2005 so not surprised.
V6 didn't work. I have an ECU now so watch this space.

200 BRM
Engine ECU worked in MEMS2J mode. Diagnostic plug was pushed into the bracket from the wrong side. Airbag ECU didn't work.

MG ZR petrol.
MEMS3 worked. I think airbag and ABS worked but my memory is not 100% on this. I guess if it didn't I would remember that.

I also demo'ed the Raspberry Pi to Tom and exported the display to my wife's tablet. I'm not sure that he was that impressed. To be honest it's a bit of a hack/geek thing (you have to configure a Pi to do it).

Now for some common questions that I had:-

You're the guy with the T4 thing?

No it's not a T4. This has good points and bad.

Bad: You can't configure anything. If you want to modify your car, replace a blown ECU, or program a new key you will still need a T4 guy. Some of the code definitions aren't as good either (it tells you the code but the descriptive text isn't pucka Rover).

Good: It's cheap. It's simple to use. You cannot damage your car with it as it only reads codes and live data.

Will it work with my ipad / iphone?

Not easily. I looked at Apples development model and I would need an Apple PC or laptop, and ipad or iphone, and an Apple development license. This is a 2 grand investment that just isn't worth it.

I forgot to take a video of it working on a 75. Sorry about that. I have a plan to do one tonight.

Thanks, Philip

oh and please buy one is offline  
The Following User Says Thank You to For This Useful Post: