Go Back   The 75 and ZT Owners Club Forums > The 75 and ZT Owners Club Forums > Technical Help Forum
Register FAQ Image Gallery Members List Calendar Search Today's Posts Mark Forums Read
Notices

Reply
 
Thread Tools Display Modes
Old 9th March 2017, 10:08   #1
RJ303
Loves to post
 
RJ303's Avatar
 
MG ZT

Join Date: Jun 2011
Location: Kingston Upon Hull
Posts: 480
Thanks: 71
Thanked 25 Times in 24 Posts
Default Refitting locking ring on in tank fuel pump

So it's a simple process to unscrew it but putting it back on is quite something else, does it screw round till tight or is it a bayonet style fitting as it appears to be. It gets tight then the more you turn it comes off again.... it's really starting to annoy me can someone explain this?
__________________
MG ZT CDTi+ 160 remap/EGR bypass/Viton O-rings
RJ303 is offline   Reply With Quote
Old 9th March 2017, 10:29   #2
RJ303
Loves to post
 
RJ303's Avatar
 
MG ZT

Join Date: Jun 2011
Location: Kingston Upon Hull
Posts: 480
Thanks: 71
Thanked 25 Times in 24 Posts
Default

Done it! I didn't have the seal seated correctly

However the car refuses to start !!!
__________________
MG ZT CDTi+ 160 remap/EGR bypass/Viton O-rings

Last edited by RJ303; 9th March 2017 at 11:00..
RJ303 is offline   Reply With Quote
Old 9th March 2017, 14:04   #3
T-Cut
This is my second home
 
Rover75 and Mreg Corsa.

Join Date: Nov 2006
Location: Sumweer onat mote o'dust (Sagin)
Posts: 20,979
Thanks: 277
Thanked 3,238 Times in 2,636 Posts
Default

Quote:
Originally Posted by RJ303 View Post
Done it! I didn't have the seal seated correctly
For anyone wondering what the correct way is, it's detailed here:http://www.the75andztclub.co.uk/foru...ead.php?t=9108

This describes working on the filter module but refitting the pump module is identical.

TC
T-Cut is offline   Reply With Quote
Old 10th March 2017, 01:28   #4
Dragrad
This is my second home
 
None at the moment

Join Date: Aug 2007
Location: Cardigan
Posts: 33,369
Thanks: 1,256
Thanked 1,632 Times in 1,075 Posts
Default

Thread moved to a more appropriate forum. Re-direct left in old. This may be the better forum as threads get ‘lost’ very quickly in the General Forum.
__________________

Andrew
Ich Dien
Problem solving is... lateral thinking

SEARCH FIRST ...ASK LATER...

Dragrad is offline   Reply With Quote
Old 10th March 2017, 16:55   #5
minimutly
Posted a thing or two
 
mg zt

Join Date: Mar 2014
Location: cardigan
Posts: 1,099
Thanks: 30
Thanked 186 Times in 158 Posts
Default

Quote:
Originally Posted by RJ303 View Post
Done it! I didn't have the seal seated correctly

However the car refuses to start !!!
Yes, I did that
minimutly is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +1. The time now is 02:37.


Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.
Copyright © 2006-2020, The Rover 75 & MG ZT Owners Club Ltd