Go Back   The 75 and ZT Owners Club Forums > The 75 and ZT Owners Club Forums > Technical Help Forum
Register FAQ Image Gallery Members List Calendar Mark Forums Read
Notices

Reply
 
Thread Tools Display Modes
Old 1st July 2021, 15:32   #1
Ravinder
This is my second home
 
Ravinder's Avatar
 
Rover 75 saloon x2, Rover 75 Tourer x2, Rover 220 Coupe Turbo

Join Date: Aug 2010
Location: Kirkcaldy, Fife
Posts: 9,023
Thanks: 2,278
Thanked 2,852 Times in 1,718 Posts
Default Diesel tourer not starting

Iíve not started my diesel tourer for a couple of weeks. Went to start it today and nothing. It didnít crank. Lights came on the dash as normal. Noticed the rear wiper going as well but not starting. Is this just a flat battery?
In the past when Iíve had a flat battery, it normally makes a clicking noise.

Thanks.
__________________
Wanted - Indian bride. Cash waiting. (All sorted - bargain)





First name and forum name: Ravinder

Rover 75 2.0 CDT Connoisseur SE 116 (160 remap)
Royal Blue (JFM)

This vehicle was the 50,481st 75 to run off the production line, out of 112,381
This vehicle was the 2,238th 75 CDT Connoisseur SE to be made out of 3,775
This vehicle was the 5,002nd 75 in Royal Blue (code: JFM) to be made out of 14,420 Royal Blue 75s
Ravinder is offline   Reply With Quote
Old 1st July 2021, 16:45   #2
Number 6
This is my second home
 
Rover 75 tourer Club CD/Limo Tints

Join Date: Nov 2008
Location: Meneac
Posts: 6,759
Thanks: 5,007
Thanked 1,609 Times in 869 Posts
Default

Quote:
Originally Posted by Ravinder View Post
Iíve not started my diesel tourer for a couple of weeks. Went to start it today and nothing. It didnít crank. Lights came on the dash as normal. Noticed the rear wiper going as well but not starting. Is this just a flat battery?
In the past when Iíve had a flat battery, it normally makes a clicking noise.

Thanks.
When I have had a flat battery (recently) The headlamps flashed and also a rapid clicking. swapped the battery and all was fine. I would suggest charging your battery for 24 hours and then try it again, Or swap it for a known good battery.
__________________
]

"I started out with nothing, and Ive still got most of it left!"
Number 6 is offline   Reply With Quote
Old 1st July 2021, 17:54   #3
75driver
Posted a thing or two
 
75driver's Avatar
 
Rover 75 saloon, manual. Rover 75 Tourer, Auto.

Join Date: Jan 2013
Location: Newry
Posts: 1,774
Thanks: 574
Thanked 443 Times in 371 Posts
Default

Quote:
Originally Posted by Ravinder View Post
Iíve not started my diesel tourer for a couple of weeks. Went to start it today and nothing. It didnít crank. Lights came on the dash as normal. Noticed the rear wiper going as well but not starting. Is this just a flat battery?
In the past when Iíve had a flat battery, it normally makes a clicking noise.

Thanks.

Does the oil light come on Ravinder?


Sent from my iPhone using Tapatalk
__________________
2006 75 Contemporary SE diesel manual (#1)

2003 75T Connoisseur SE diesel auto (For Comfort)
2005 75 Connoisseur SE diesel auto (Marmite duotone )
2006 75 Connoisseur SE diesel auto (The last one?)

2009 E220 (For a change)
2018 L200 (For Big & Heavy Things)
1976 W114 250 Manual (For Sundays)
75driver is offline   Reply With Quote
Old 1st July 2021, 17:56   #4
Ravinder
This is my second home
 
Ravinder's Avatar
 
Rover 75 saloon x2, Rover 75 Tourer x2, Rover 220 Coupe Turbo

Join Date: Aug 2010
Location: Kirkcaldy, Fife
Posts: 9,023
Thanks: 2,278
Thanked 2,852 Times in 1,718 Posts
Default

Iím away from the car now but I think all the lights came on. Iím going to try jumping it and see if that works.

In the past, Iíve had rapid clicking as well when the battery has gone flat but it didnít make any noise at all this time.


Sent from my iPhone using Tapatalk
__________________
Wanted - Indian bride. Cash waiting. (All sorted - bargain)





First name and forum name: Ravinder

Rover 75 2.0 CDT Connoisseur SE 116 (160 remap)
Royal Blue (JFM)

This vehicle was the 50,481st 75 to run off the production line, out of 112,381
This vehicle was the 2,238th 75 CDT Connoisseur SE to be made out of 3,775
This vehicle was the 5,002nd 75 in Royal Blue (code: JFM) to be made out of 14,420 Royal Blue 75s
Ravinder is offline   Reply With Quote
Old 1st July 2021, 18:35   #5
Number 6
This is my second home
 
Rover 75 tourer Club CD/Limo Tints

Join Date: Nov 2008
Location: Meneac
Posts: 6,759
Thanks: 5,007
Thanked 1,609 Times in 869 Posts
Default

Quote:
Originally Posted by Ravinder View Post
Iím away from the car now but I think all the lights came on. Iím going to try jumping it and see if that works.

In the past, Iíve had rapid clicking as well when the battery has gone flat but it didnít make any noise at all this time.


Sent from my iPhone using Tapatalk
It could be that the battery has completely died,, When you jump start it make sure you attach the earth jump lead to a point on the engine, and of course the the live to the battery terminal(red) ,The reason being my battery was completely F.U.B.A.R.D and would let the jumper battery power pass thru it.
__________________
]

"I started out with nothing, and Ive still got most of it left!"
Number 6 is offline   Reply With Quote
Old 1st July 2021, 18:43   #6
COLVERT
This is my second home
 
R75 Saloon.

Join Date: Feb 2009
Location: France/or Devon.
Posts: 14,003
Thanks: 3,851
Thanked 2,167 Times in 1,816 Posts
Default

[QUOTE=Number 6;2889343]It could be that the battery has completely died,, When you jump start it make sure you attach the earth jump lead to a point on the engine, and of course the the live to the battery terminal(red) ,The reason being my battery was completely F.U.B.A.R.D and would let the jumper battery power pass thru it. [/QUOTE

Actually the power from the jump leads doesn't need to go through the battery.

You could take the battery out and the car would start quite happily with just the jump leads attached.---



PS.--FUBAR


Here endeth todays lesson.---
COLVERT is offline   Reply With Quote
Old 1st July 2021, 18:48   #7
COLVERT
This is my second home
 
R75 Saloon.

Join Date: Feb 2009
Location: France/or Devon.
Posts: 14,003
Thanks: 3,851
Thanked 2,167 Times in 1,816 Posts
Default

Quote:
Originally Posted by Ravinder View Post
Iíve not started my diesel tourer for a couple of weeks. Went to start it today and nothing. It didnít crank. Lights came on the dash as normal. Noticed the rear wiper going as well but not starting. Is this just a flat battery?
In the past when Iíve had a flat battery, it normally makes a clicking noise.

Thanks.
You say---lights came on plus the wiper.

No clicking however, so it's your solenoid that's stopped working or the small lead (Tag. ) that's making a bad contact.
COLVERT is offline   Reply With Quote
Old 1st July 2021, 18:52   #8
stevestrat
This is my second home
 
ZT260 #243 (resting)

Join Date: May 2010
Location: Prestonpans
Posts: 22,352
Thanks: 650
Thanked 4,624 Times in 3,358 Posts
Default

I'd stick a voltmeter across the battery before getting overcomplicated about it.
__________________
Steve


T4 Location Map
stevestrat is offline   Reply With Quote
Old 1st July 2021, 19:03   #9
COLVERT
This is my second home
 
R75 Saloon.

Join Date: Feb 2009
Location: France/or Devon.
Posts: 14,003
Thanks: 3,851
Thanked 2,167 Times in 1,816 Posts
Default

Your battery needs to show at least around 12.3 to 12.4 volts to trip the solenoid.

You say your dash lights came on.--When you turned the ignition key did the lights go out ??
COLVERT is offline   Reply With Quote
Old 1st July 2021, 19:37   #10
Number 6
This is my second home
 
Rover 75 tourer Club CD/Limo Tints

Join Date: Nov 2008
Location: Meneac
Posts: 6,759
Thanks: 5,007
Thanked 1,609 Times in 869 Posts
Default

Quote:
Originally Posted by Ravinder View Post
Iím away from the car now but I think all the lights came on. Iím going to try jumping it and see if that works.

In the past, Iíve had rapid clicking as well when the battery has gone flat but it didnít make any noise at all this time.


Sent from my iPhone using Tapatalk
It could be that the battery has completely died,, When you jump start it make sure you attach the earth jump lead to a point on the engine, and of course the the live to the battery terminal(red) ,The reason being my battery was completely F.U.B.A.R.D and would let the jumper battery power pass thru it.
__________________
]

"I started out with nothing, and Ive still got most of it left!"
Number 6 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 13:39.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2024, vBulletin Solutions Inc.
Copyright © 2006-2023, The Rover 75 & MG ZT Owners Club Ltd