Go Back   The 75 and ZT Owners Club Forums > The 75 and ZT Owners Club Forums > The 75 and ZT Owners Club General Forum
Register FAQ Image Gallery Members List Calendar Search Today's Posts Mark Forums Read
Notices

Reply
 
Thread Tools Display Modes
Old 15th April 2019, 12:24   #1
andrewscruff
Avid contributor
 
andrewscruff's Avatar
 
rover 75

Join Date: Dec 2013
Location: bishops stortford
Posts: 180
Thanks: 62
Thanked 9 Times in 8 Posts
Default Rover75 1800 turbo coolant loss

Can anyone help losing coolant around half a pint a day no wet patches under the car cap not leaking what should I be looking at carpets are dry!


Sent from my iPhone using Tapatalk
__________________
andrewscruff is offline   Reply With Quote
Old 15th April 2019, 12:31   #2
Lovel
T4 Diagnostics
 
Lovel's Avatar
 
R40, P6B, L359, Imp, R56, Street Twin

Join Date: Nov 2006
Location: Aberdeenshire
Posts: 2,586
Thanks: 229
Thanked 490 Times in 337 Posts
Default

Quote:
Originally Posted by andrewscruff View Post
Can anyone help losing coolant around half a pint a day no wet patches under the car cap not leaking what should I be looking at carpets are dry!


Sent from my iPhone using Tapatalk
Sump oil level increasing ? Coolant sits below oil until it eventually reaches oil pump intake then mixes to a mayonnaise over time

Inlet manifold leaking gasket or gasket not being squeezed enough? Rough running from cold? Cleaner looking spark plugs on cylinders 1&2? Compared to 2&3?
__________________
@@@@@ Genuine NOS Hillman Imp body panels wanted @@@@@@ Almost there just need a Bonnet & Front Headlamp Panel
Lovel is offline   Reply With Quote
The Following User Says Thank You to Lovel For This Useful Post:
Old 15th April 2019, 12:33   #3
andrewscruff
Avid contributor
 
andrewscruff's Avatar
 
rover 75

Join Date: Dec 2013
Location: bishops stortford
Posts: 180
Thanks: 62
Thanked 9 Times in 8 Posts
Default

Car is running fine no miss fire at all


Sent from my iPhone using Tapatalk
__________________
andrewscruff is offline   Reply With Quote
Old 15th April 2019, 12:35   #4
andrewscruff
Avid contributor
 
andrewscruff's Avatar
 
rover 75

Join Date: Dec 2013
Location: bishops stortford
Posts: 180
Thanks: 62
Thanked 9 Times in 8 Posts
Default

All new plugs plea coils replaced


Sent from my iPhone using Tapatalk
__________________
andrewscruff is offline   Reply With Quote
Old 15th April 2019, 13:35   #5
trikey
Premium Trader
 
trikey's Avatar
 
T4

Join Date: Nov 2010
Location: Norfolk
Posts: 22,982
Thanks: 4,798
Thanked 7,641 Times in 4,600 Posts
Default

Water pump leak, Iíve just changed mine at the weekend.

__________________
Lest we forget..
trikey is offline   Reply With Quote
Old 15th April 2019, 19:10   #6
neilb740
I really should get out more.......
 
neilb740's Avatar
 
MG ZT 1.8

Join Date: Oct 2011
Location: Crewe
Posts: 2,298
Thanks: 110
Thanked 345 Times in 235 Posts
Default

Manifold gasket?
Any red staining down the back of the engine?.
I rarely saw any coolant under the car when mine went, it evaporates as it runs down the hot engine block but leaves pink/red stains as it dries.
neilb740 is offline   Reply With Quote
The Following User Says Thank You to neilb740 For This Useful Post:
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +1. The time now is 04:54.


Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Copyright © 2006-2019, The Rover 75 & MG ZT Owners Club Ltd