Go Back   The 75 and ZT Owners Club Forums > The 75 and ZT Owners Club Forums > Technical Help Forum
Register FAQ Image Gallery Members List Calendar Search Today's Posts Mark Forums Read
Notices

Reply
 
Thread Tools Display Modes
Old 21st June 2022, 19:23   #1
paulh260260
Still learning...
 
paulh260260's Avatar
 
Gold 04 75 Connie SE 2.5 V6 Petrol, Silver 52 Connie SE 2.5 V6 Petrol, 04 BRG Connie 2.5 V6 Petrol

Join Date: Sep 2009
Location: MANCHESTER
Posts: 199
Thanks: 123
Thanked 37 Times in 24 Posts
Default Anyone close to Manchester that can help with an EP problem?

Just started my 04 2.5 Petrol Connie Auto only to get the dreaded EP on the display.

I've disconnected the battery for 15 mins but still the same, I've also checked the plenum and it's bone dry.

Haven't had any gearbox judders to suggest its the 2/4 solenoid, although it judders now, is that just due to the emergency mode or could that suggest the solenoid needs replacing?

Is there anything else I can do to either eliminate a problem or narrow it down myself?

If not as the header suggest is there anyone close to Manchester who could have a look and maybe help?

Cheers

Paul
__________________
Still figuring out where this last nut goes...
paulh260260 is offline   Reply With Quote
Old 21st June 2022, 19:39   #2
Yorkshire GOC
Posted a thing or two
 
Yorkshire GOC's Avatar
 
MG ZT-T 1.8T 200 Kmaps Remap

Join Date: May 2014
Location: Hull
Posts: 1,799
Thanks: 1,773
Thanked 586 Times in 439 Posts
Default

I would go to Big Russ at Liversedge a maestro on our cars and a T4 operator - only 35 miles or so from you - drop him a PM.
__________________
  • 5,365th ZT-T to run off the production line, out of 8,249
  • 59th ZT-T 160 (1.8T) to be made out of 118
  • 894th ZT-T in XPower Grey to be made out of 1,673 XPower Grey ZT-T's

DISAPPOINTING GREY AND PROUD
Yorkshire GOC is offline   Reply With Quote
The Following 2 Users Say Thank You to Yorkshire GOC For This Useful Post:
Old 21st June 2022, 20:47   #3
paulh260260
Still learning...
 
paulh260260's Avatar
 
Gold 04 75 Connie SE 2.5 V6 Petrol, Silver 52 Connie SE 2.5 V6 Petrol, 04 BRG Connie 2.5 V6 Petrol

Join Date: Sep 2009
Location: MANCHESTER
Posts: 199
Thanks: 123
Thanked 37 Times in 24 Posts
Default

Quote:
Originally Posted by Yorkshire GOC View Post
I would go to Big Russ at Liversedge a maestro on our cars and a T4 operator - only 35 miles or so from you - drop him a PM.
You're right Russ is a maestro and a nice guy but as I'm in Emergency Mode I cant get over to him ( even if its only 35 miles away!!!)The M62 is not the ideal road to be schlepping at 10 mph!!!!

I really need someone one in the know to come over to me to check it out and determine the fault in the first instance.

Paul
__________________
Still figuring out where this last nut goes...
paulh260260 is offline   Reply With Quote
Old 22nd June 2022, 00:27   #4
Eddiebassman
Avid contributor
 
Rover 75 2.0 cdti tourer connoisseur se

Join Date: Jul 2020
Location: Halifax
Posts: 221
Thanks: 30
Thanked 22 Times in 20 Posts
Default

Iíve known Russ travel in the past but no idea how far. Iíd ask him, but of course pay him for the travel and time if he does.

The only guy I use for none heavy work


Sent from my iPhone using Tapatalk
Eddiebassman is offline   Reply With Quote
The Following User Says Thank You to Eddiebassman For This Useful Post:
Old 22nd June 2022, 13:02   #5
SD1too
Doesn't do things by halves
 
SD1too's Avatar
 
Rover 75 2.5 Connoisseur Auto (1999) Dealer launch model.

Join Date: Mar 2007
Location: Former Middlesex
Posts: 19,159
Thanks: 1,538
Thanked 3,710 Times in 3,147 Posts
Default

Hello Paul,

Strange as it may seem, the 'EP' indication does not necessarily mean a gearbox fault. It could be CAN bus communication problems with the automatic transmission ECU.

To rule this out, are your tachometer, temperature gauge, PRNDL display, check engine lamp and traction control (if fitted) displaying normally in the instrument binnacle?

Simon
__________________
"Whatever is rightly done, however humble, is noble."
Sir Henry Royce.
SD1too is offline   Reply With Quote
The Following User Says Thank You to SD1too For This Useful Post:
Old 22nd June 2022, 13:24   #6
paulh260260
Still learning...
 
paulh260260's Avatar
 
Gold 04 75 Connie SE 2.5 V6 Petrol, Silver 52 Connie SE 2.5 V6 Petrol, 04 BRG Connie 2.5 V6 Petrol

Join Date: Sep 2009
Location: MANCHESTER
Posts: 199
Thanks: 123
Thanked 37 Times in 24 Posts
Default

Quote:
Originally Posted by SD1too View Post
Hello Paul,

Strange as it may seem, the 'EP' indication does not necessarily mean a gearbox fault. It could be CAN bus communication problems with the automatic transmission ECU.

To rule this out, are your tachometer, temperature gauge, PRNDL display, check engine lamp and traction control (if fitted) displaying normally in the instrument binnacle?

Simon
Hi Simon

Funnily enough the tacho and temp display weren't working, however I've just connected TOAF, scanned the engine then cleared all DTC's and the car is back to normal.

The next challenge, of course, is to determine what caused the fault in the first place, and try to prevent it happening again.

It sounds as if there could be a potential problem in the CAN bus

Cheers

Paul
__________________
Still figuring out where this last nut goes...
paulh260260 is offline   Reply With Quote
The Following User Says Thank You to paulh260260 For This Useful Post:
Old 22nd June 2022, 13:36   #7
trikey
Premium Trader
 
trikey's Avatar
 
75 & ZTT

Join Date: Nov 2010
Location: Norfolk
Posts: 32,449
Thanks: 8,766
Thanked 14,718 Times in 7,979 Posts
Default

What happens when you reset the gearbox ecu by pulling fuse 4 in the engine bay?

Sent from my SM-G780G using Tapatalk
__________________
Lest we forget..
trikey is offline   Reply With Quote
The Following User Says Thank You to trikey For This Useful Post:
Old 22nd June 2022, 13:46   #8
SD1too
Doesn't do things by halves
 
SD1too's Avatar
 
Rover 75 2.5 Connoisseur Auto (1999) Dealer launch model.

Join Date: Mar 2007
Location: Former Middlesex
Posts: 19,159
Thanks: 1,538
Thanked 3,710 Times in 3,147 Posts
Default

Quote:
Originally Posted by paulh260260 View Post
Hi Simon
Funnily enough the tacho and temp display weren't working ... It sounds as if there could be a potential problem in the CAN bus.
The CAN bus communication between the Engine Control Module and Instrument Pack has an intermittent fault [Source: RAVE].

It's good to know it's not the gearbox eh?

Simon
__________________
"Whatever is rightly done, however humble, is noble."
Sir Henry Royce.
SD1too is offline   Reply With Quote
Old 22nd June 2022, 13:57   #9
paulh260260
Still learning...
 
paulh260260's Avatar
 
Gold 04 75 Connie SE 2.5 V6 Petrol, Silver 52 Connie SE 2.5 V6 Petrol, 04 BRG Connie 2.5 V6 Petrol

Join Date: Sep 2009
Location: MANCHESTER
Posts: 199
Thanks: 123
Thanked 37 Times in 24 Posts
Default

Quote:
Originally Posted by SD1too View Post
The CAN bus communication between the Engine Control Module and Instrument Pack has an intermittent fault [Source: RAVE].

It's good to know it's not the gearbox eh?

Simon
Oh yes!! Now if you've just got that from RAVE I'm going to have a good look at the disk as it's actually in my laptop anyway ( think it spends most of its life in there!!!)
__________________
Still figuring out where this last nut goes...
paulh260260 is offline   Reply With Quote
Old 22nd June 2022, 14:00   #10
paulh260260
Still learning...
 
paulh260260's Avatar
 
Gold 04 75 Connie SE 2.5 V6 Petrol, Silver 52 Connie SE 2.5 V6 Petrol, 04 BRG Connie 2.5 V6 Petrol

Join Date: Sep 2009
Location: MANCHESTER
Posts: 199
Thanks: 123
Thanked 37 Times in 24 Posts
Default

Quote:
Originally Posted by trikey View Post
What happens when you reset the gearbox ecu by pulling fuse 4 in the engine bay?

Sent from my SM-G780G using Tapatalk
Haven't tried that Andy but as its working is it still worth trying or best left alone now?

Paul
__________________
Still figuring out where this last nut goes...
paulh260260 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +1. The time now is 04:35.


Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2022, Jelsoft Enterprises Ltd.
Copyright © 2006-2022, The Rover 75 & MG ZT Owners Club Ltd