Go Back   The 75 and ZT Owners Club Forums > The 75 and ZT Owners Club Forums > Technical Help Forum
Register FAQ Image Gallery Members List Calendar Search Today's Posts Mark Forums Read
Notices

Reply
 
Thread Tools Display Modes
Old 13th May 2022, 12:41   #1
dingdong1960
Newbie
 
dingdong1960's Avatar
 
rover 75 saloon

Join Date: Jan 2017
Location: huddersfield
Posts: 12
Thanks: 10
Thanked 2 Times in 2 Posts
Default Over heating diesel

Hi ..diesel ...runs normal temp around town ..soon as i go up hill ..car overheats !.and starts rattling ! ..which stops as car cools down ...any ideas??
Fan works ok ...no bubbles in header tank ..tho bottom hose dosnt seem to get hot ..unlike top hose ...
dingdong1960 is offline   Reply With Quote
Old 13th May 2022, 12:55   #2
tourer
Posted a thing or two
 
Rover 75 Tourer CDT Auto.

Join Date: Oct 2011
Location: Long Eaton
Posts: 1,304
Thanks: 30
Thanked 215 Times in 159 Posts
Smile

Quote:
Originally Posted by dingdong1960 View Post
Hi ..diesel ...runs normal temp around town ..soon as i go up hill ..car overheats !.and starts rattling ! ..which stops as car cools down ...any ideas??
Fan works ok ...no bubbles in header tank ..tho bottom hose dosnt seem to get hot ..unlike top hose ...
Hi.

Over eating owner!
I also get hot going uphill.
Bottom hose also been known to get hot in certain circumstances.
tourer is offline   Reply With Quote
The Following User Says Thank You to tourer For This Useful Post:
Old 13th May 2022, 13:11   #3
Ducati750cc
Loves to post
 
Rover75 tourer

Join Date: Jun 2018
Location: Ashton
Posts: 300
Thanks: 108
Thanked 176 Times in 121 Posts
Default

Quote:
Originally Posted by dingdong1960 View Post
Hi ..diesel ...runs normal temp around town ..soon as i go up hill ..car overheats !.and starts rattling ! ..which stops as car cools down ...any ideas??
Fan works ok ...no bubbles in header tank ..tho bottom hose dosnt seem to get hot ..unlike top hose ...



It could be a faulty thermostat or other part of the cooling system preventing the correct coolant flow when hot, especially as the bottom hose is notably cooler


Does the noise sound more like a crackling sound than a rattle? you can get this noise when due to insufficient cooling, or sluggish coolant flow, when the coolant reaches the hottest parts of the head, which will be hotter than normal, it forms ' steam ' bubbles, this steam bubble quickly reverts back to water due to the bubble moving through the cooler coolant and the coolant being under pressure.


There will be no bubbles seen in the coolant when this happens.


When it's doing it you should also be able to feel the pulses in the top hose with engine off if you're quick.
__________________
Common sense isn't a gift, it's a punishment because you have to deal with everyone who doesn't have it.
Ducati750cc is offline   Reply With Quote
The Following User Says Thank You to Ducati750cc For This Useful Post:
Old 13th May 2022, 17:08   #4
dingdong1960
Newbie
 
dingdong1960's Avatar
 
rover 75 saloon

Join Date: Jan 2017
Location: huddersfield
Posts: 12
Thanks: 10
Thanked 2 Times in 2 Posts
Default

certainly a rattle !..
dingdong1960 is offline   Reply With Quote
Old 13th May 2022, 17:09   #5
dingdong1960
Newbie
 
dingdong1960's Avatar
 
rover 75 saloon

Join Date: Jan 2017
Location: huddersfield
Posts: 12
Thanks: 10
Thanked 2 Times in 2 Posts
Default

yep sounds like me too ...tho bottom hose soft and limp !!
dingdong1960 is offline   Reply With Quote
Old 13th May 2022, 17:34   #6
dave lincs
Posted a thing or two
 
Rover 75 Saloon

Join Date: Mar 2014
Location: Louth
Posts: 1,071
Thanks: 324
Thanked 802 Times in 402 Posts
Default

Does the heater work if set on full heat? last time i had one do this the impeller had fallen off the water pump
dave lincs is offline   Reply With Quote
The Following User Says Thank You to dave lincs For This Useful Post:
Old 14th May 2022, 05:42   #7
dingdong1960
Newbie
 
dingdong1960's Avatar
 
rover 75 saloon

Join Date: Jan 2017
Location: huddersfield
Posts: 12
Thanks: 10
Thanked 2 Times in 2 Posts
Default

Yes heater works fine ..
dingdong1960 is offline   Reply With Quote
Old 14th May 2022, 08:24   #8
SD1too
Doesn't do things by halves
 
SD1too's Avatar
 
Rover 75 2.5 Connoisseur Auto (1999) Dealer launch model.

Join Date: Mar 2007
Location: Middlesex
Posts: 18,984
Thanks: 1,494
Thanked 3,629 Times in 3,076 Posts
Default

Quote:
Originally Posted by dingdong1960 View Post
... tho bottom hose dosnt seem to get hot ...
It's almost certainly your thermostat stuck or not opening fully Chris. They're known to be unreliable on the diesel.

Simon
__________________
"Whatever is rightly done, however humble, is noble."
Sir Henry Royce.
SD1too is offline   Reply With Quote
The Following User Says Thank You to SD1too For This Useful Post:
Old 14th May 2022, 08:49   #9
Arctic
Give to Learn
 
Arctic's Avatar
 
Rover 75 Tourer

Join Date: Aug 2010
Location: West Midlands
Posts: 16,587
Thanks: 1,031
Thanked 5,832 Times in 3,526 Posts
Default

Hi Chris.
You say the fan is working have you done the demist test? also as above the original thermostats on the diesel tend to open slowly, so maybe it's not fully open when you go up hill, how far have you travelled to the said hill or is it all hills even if you have been driving for an hour or more?
__________________
Arctic
Givology Learn to Give
Everything is Achievable

ad altiora tendo.

Check out our Nano meet dates
http://www.midlandsnanomeets.co.uk/

http://www.the75andztclub.co.uk/index.php?thepage=howto

" You do the work , we supply the expertise "
Arctic is offline   Reply With Quote
The Following User Says Thank You to Arctic For This Useful Post:
Old 14th May 2022, 16:37   #10
dingdong1960
Newbie
 
dingdong1960's Avatar
 
rover 75 saloon

Join Date: Jan 2017
Location: huddersfield
Posts: 12
Thanks: 10
Thanked 2 Times in 2 Posts
Default

Hello there ..thanks all for helpful replies ..Arctic ...demist test ????think i had done approx 10-15 miles ..its all hills around here !!! ..diesel tourer i had previously was exact opposite ..ran really cold til i did thermostat in top hose trick ...temp gauge rises to half way and stays there til i up a bl**dy hill !! i then have to put heater on full to help cool it ..fan comes on ok ..also starts rattling too ( water pump impeller ?)...its not losing or using coolant ..nearest 75 guy cant look at it til mid june ..
dingdong1960 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +1. The time now is 01:25.


Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2022, Jelsoft Enterprises Ltd.
Copyright © 2006-2022, The Rover 75 & MG ZT Owners Club Ltd