Go Back   The 75 and ZT Owners Club Forums > The 75 and ZT Owners Club Forums > Technical Help Forum
Register FAQ Image Gallery Members List Calendar Search Today's Posts Mark Forums Read
Notices

Reply
 
Thread Tools Display Modes
Old 5th December 2018, 14:02   #1
steve-45
I really should get out more.......
 
steve-45's Avatar
 
Rover 75 Saloon CDTi

Join Date: Oct 2015
Location: Belvedere, Kent.
Posts: 2,989
Thanks: 65
Thanked 655 Times in 521 Posts
Default ABS warning light

Just started recently, when I turn the engine off the yellow ABS warning light on the dash glows faintly for about 2 seconds!

Any thoughts on what maybe causing this ?
steve-45 is online now   Reply With Quote
Old 5th December 2018, 14:25   #2
Heddy
Will always have a 75
 
Heddy's Avatar
 
Rover 75 Mk2. Diesel. Manual.

Join Date: Feb 2013
Location: Exmouth.
Posts: 5,058
Thanks: 401
Thanked 1,030 Times in 822 Posts
Default

No idea......but mine does it too.
__________________
If it isn't a 75 then it's just a car.
Heddy is offline   Reply With Quote
Old 5th December 2018, 16:35   #3
steve-45
I really should get out more.......
 
steve-45's Avatar
 
Rover 75 Saloon CDTi

Join Date: Oct 2015
Location: Belvedere, Kent.
Posts: 2,989
Thanks: 65
Thanked 655 Times in 521 Posts
Default

Has it been doing it for long ?
steve-45 is online now   Reply With Quote
Old 6th December 2018, 09:55   #4
Chuckles
Loves to post
 
1999 - 75 2.0Ltr Connoisseur SE petrol Saloon

Join Date: Jan 2012
Location: Iwerne Minster
Posts: 462
Thanks: 41
Thanked 38 Times in 35 Posts
Default

Been through any deep puddles lately?
check the multi-plug on the ABS unit for water ingress - see my postings over the last couple of years.
__________________
Chuck
Nth. Dorset. UK
Membership #1896
Don't take life so seriously.... it is not permanent! I also have its Granddad! 1963 Rover 3 litre Coupe'
Chuckles is offline   Reply With Quote
Old 6th December 2018, 18:05   #5
steve-45
I really should get out more.......
 
steve-45's Avatar
 
Rover 75 Saloon CDTi

Join Date: Oct 2015
Location: Belvedere, Kent.
Posts: 2,989
Thanks: 65
Thanked 655 Times in 521 Posts
Default

Tend not to use the 75 in the wet at the moment as I have use of a second car.

But I will certainly check the wiring plugs to the ABS unit
steve-45 is online now   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +1. The time now is 20:41.


Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
Copyright © 2006-2018, The Rover 75 & MG ZT Owners Club Ltd