Go Back   The 75 and ZT Owners Club Forums > The 75 and ZT Owners Club Forums > Technical Help Forum
Register FAQ Image Gallery Members List Calendar Mark Forums Read
Notices

 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
Old 18th April 2024, 14:37   #1
bearhouse
Avid contributor
 
Rover 75

Join Date: Aug 2009
Location: Herts
Posts: 118
Thanks: 0
Thanked 0 Times in 0 Posts
Default Fault code - recirculating pump

Hi All,

Been having ABS and Brake Fault Issues. As per recommendations on this forum, Iíve had the rear discs and pads removed and the dust cleaned around the ABS sensors. In fact, I had the ABS sensors replaced at the same time. Then I had the connector removed from the ABS pump. It appears to have been wet in the past so was cleaned with contact cleaner. All put back together. There was initial fault codes of recirculating pump and right rear ABS sensor. The rear ABS sensor has cleared but the recirculating pump fault has returned.

Question, what is the recirculating pump? Is it the ABS pump or something different? Is it fixable?

Any wise words greatly appreciated.

Regards,
Terry
bearhouse is offline   Reply With Quote
 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 16:20.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2024, vBulletin Solutions Inc.
Copyright © 2006-2023, The Rover 75 & MG ZT Owners Club Ltd