Go Back   The 75 and ZT Owners Club Forums > The 75 and ZT Owners Club Forums > I.C.E. Forum > Sat Nav Hardware & Software > Factory Fit Highline & Lowline Navigation Systems
Register FAQ Image Gallery Members List Calendar Search Today's Posts Mark Forums Read
Notices

Reply
 
Thread Tools Display Modes
Old 23rd November 2020, 18:30   #11
Matt G
Regular poster
 
MG ZT 190+ (Development car), mg zt 190SE (Twilight), MG ZS 180

Join Date: Nov 2017
Location: Waltham st lawrence
Posts: 37
Thanks: 5
Thanked 6 Times in 6 Posts
Default

After a day of checking I found the cause of my screen remaining blank or flicking On intermittently, down to a corroded and chaffed wire ( white / red stripe Wire ) Down at the bottom of the centre console , heater metal frame (see pic- green circle)

After a soldered repair it came straight back to life, however it has now highlight I have a further electrical gremlin, around the Sat nav drive box, which I am yet to resolve, it occosionally works, so back to wiring again.

But at least I have a screen ,radio, tape and cd drive on

Also in relation to JB tourer having his joint of wires underneath the driver seat, mine did not. I found them (purple /pink ) all soldered together behind the centre console along with a bunch black wires, so assuming as my car is a mk2 it may have been a modification by Rover on the later cars. See pic - red circle

I hope this may help someone with a similar problem in the future
Attached Images
File Type: jpg A44E3165-0CC6-437F-B12F-FCB31268D63C.jpg (17.2 KB, 8 views)
File Type: jpg 737C8011-D851-46BE-B4B3-4A5EFD37F14C.jpg (18.3 KB, 8 views)
Matt G is offline   Reply With Quote
Old 24th November 2020, 22:04   #12
Matt G
Regular poster
 
MG ZT 190+ (Development car), mg zt 190SE (Twilight), MG ZS 180

Join Date: Nov 2017
Location: Waltham st lawrence
Posts: 37
Thanks: 5
Thanked 6 Times in 6 Posts
Default

Sat Nav issue resolved, turned out to be the corroded 6 pin cable inside the Sat Nav Drive as well documented on the forum
Matt G is offline   Reply With Quote
The Following User Says Thank You to Matt G For This Useful Post:
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +1. The time now is 13:39.


Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.
Copyright © 2006-2020, The Rover 75 & MG ZT Owners Club Ltd