Go Back   The 75 and ZT Owners Club Forums > The 75 and ZT Owners Club Forums > I.C.E. Forum > Sat Nav Hardware & Software > Factory Fit Highline & Lowline Navigation Systems
Register FAQ Image Gallery Members List Calendar Search Today's Posts Mark Forums Read
Notices

Reply
 
Thread Tools Display Modes
Old 3rd July 2020, 21:21   #1
alphaeagle
Avid contributor
 
alphaeagle's Avatar
 
Rover 75 Saloon CDTi, MG ZT CDTi

Join Date: Apr 2016
Location: Portarlington
Posts: 122
Thanks: 49
Thanked 24 Times in 18 Posts
Default RReplacement GPS NAVIGATION SYSTEM CD Drive...

Hi Guys

please see link to my post concerning electrical issue on my 2004 MG-ZT..

https://the75andztclub.co.uk/forum/s...d.php?t=306047

Any way... I have reinstalled the GPs system, and the red light is staying on, but the system will not eject the disk any more.....and does not show on the screen

I will take it apart again tomorrow to make sure all connections are plugged in correctly.....

Any how I was wondering would the below work with my car...ie straight plug and play?

https://www.ebay.co.uk/itm/BMW-E46-S...sAAOSw6Qde5TEs
__________________
Working on:

Rover 75 CDTi Copperleaf

Today is just yesterdays tomorrow.....

Last edited by alphaeagle; 3rd July 2020 at 21:24..
alphaeagle is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +1. The time now is 08:30.


Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2021, Jelsoft Enterprises Ltd.
Copyright © 2006-2020, The Rover 75 & MG ZT Owners Club Ltd