Go Back   The 75 and ZT Owners Club Forums > The 75 and ZT Owners Club Forums > The 75 and ZT Owners Club General Forum
Register FAQ Image Gallery Members List Calendar Search Today's Posts Mark Forums Read
Notices

Reply
 
Thread Tools Display Modes
Old 14th February 2020, 09:19   #1
Yannage
Regular poster
 
Rover 75 saloon

Join Date: Jan 2020
Location: Farsley
Posts: 37
Thanks: 2
Thanked 7 Times in 4 Posts
Default Snow mode

A star has appeared next to D on dash. Research suggests this means snow mode is on. My misses is adamant she hasn't put it on though. Does the car autodetect this?
Yannage is offline   Reply With Quote
Old 14th February 2020, 09:25   #2
MalteseMarc
Gets stuck in
 
MalteseMarc's Avatar
 
Rover 75 CDTI connoisseur SE auto, 2004

Join Date: Sep 2008
Location: France
Posts: 995
Thanks: 131
Thanked 69 Times in 51 Posts
Default

Hi,
It's must have somehow been pressed as this is not automatically applied, the same in regards to sports mode.

Kind regards
__________________
[SIGPIC][/SIGPIC]
MalteseMarc is offline   Reply With Quote
Old 14th February 2020, 09:28   #3
rovertone
Never too old to listen & learn
 
rovertone's Avatar
 
Rover 75 Conne SE Auto CDTi

Join Date: Nov 2012
Location: Redditch
Posts: 473
Thanks: 146
Thanked 79 Times in 65 Posts
Default

The switch to the left of the gear change lever gives you the option to select 'S' Sport or '*' Snow, but IIRC when ignition was switched off the system defaults back to normal Drive.
Switch isn't sticking is it, have you tried switching between the two modes?

My car's not here at the moment so can't check.
__________________
2003 Mk 1 CDTi Connie SE Auto Monogram Mirage 2/Sandstone Leather
511th CDTi SE out of 4744 produced
9th in Mirage2 out of 17 produced

Also Rover 25 SXi CVT and still missing my 800 Fastback
rovertone is offline   Reply With Quote
Old 14th February 2020, 09:29   #4
Yannage
Regular poster
 
Rover 75 saloon

Join Date: Jan 2020
Location: Farsley
Posts: 37
Thanks: 2
Thanked 7 Times in 4 Posts
Default

Quote:
Originally Posted by rovertone View Post
The switch to the left of the gear change lever gives you the option to select 'S' Sport or '*' Snow, but IIRC when ignition was switched off the system defaults back to normal Drive.
Switch isn't sticking is it, have you tried switching between the two modes?

My car's not here at the moment so can't check.
Cars with her, I'll have to get her to try at lunch.
Yannage is offline   Reply With Quote
Old 14th February 2020, 12:37   #5
clf
This is my second home
 
clf's Avatar
 
MG ZT CDTi

Join Date: Jan 2014
Location: carrick
Posts: 6,962
Thanks: 3,082
Thanked 2,261 Times in 1,701 Posts
Default

Quote:
Originally Posted by Yannage View Post
Cars with her, I'll have to get her to try at lunch.
Does she have a handbag or purse? As she reaches it over the console, perhaps it drags onto the switch ?

Sent from my SM-A600FN using Tapatalk
__________________


It is not gloss primer .............. it is duct tape silver!
clf is offline   Reply With Quote
Old 14th February 2020, 13:57   #6
rovertone
Never too old to listen & learn
 
rovertone's Avatar
 
Rover 75 Conne SE Auto CDTi

Join Date: Nov 2012
Location: Redditch
Posts: 473
Thanks: 146
Thanked 79 Times in 65 Posts
Default

My car's now back (clean MOT, yippee!) and I have refreshed myself as I rarely use the two modes.
Firstly if either mode is selected after ignition has been switched off it does default to normal drive.
To engage Sport Mode you slide switch forward, to engage Snow mode press the switch down, so anything resting on the switch?
__________________
2003 Mk 1 CDTi Connie SE Auto Monogram Mirage 2/Sandstone Leather
511th CDTi SE out of 4744 produced
9th in Mirage2 out of 17 produced

Also Rover 25 SXi CVT and still missing my 800 Fastback
rovertone is offline   Reply With Quote
Old 14th February 2020, 18:16   #7
trikey
Premium Trader
 
trikey's Avatar
 
T4

Join Date: Nov 2010
Location: Norfolk
Posts: 27,869
Thanks: 6,548
Thanked 10,487 Times in 6,170 Posts
Default

The normal mode will be enabled once the ignition is cycled.
__________________
Lest we forget..
trikey is offline   Reply With Quote
Old 18th February 2020, 13:21   #8
Yannage
Regular poster
 
Rover 75 saloon

Join Date: Jan 2020
Location: Farsley
Posts: 37
Thanks: 2
Thanked 7 Times in 4 Posts
Default

It was a false alarm... the next time the engine was switched on it was back to normal. I wasn't too sure if there were known issues about this but it seems not.
Yannage is offline   Reply With Quote
The Following User Says Thank You to Yannage For This Useful Post:
Old 18th February 2020, 14:00   #9
clf
This is my second home
 
clf's Avatar
 
MG ZT CDTi

Join Date: Jan 2014
Location: carrick
Posts: 6,962
Thanks: 3,082
Thanked 2,261 Times in 1,701 Posts
Default

Quote:
Originally Posted by Yannage View Post
It was a false alarm... the next time the engine was switched on it was back to normal. I wasn't too sure if there were known issues about this but it seems not.
tell her to lift her handbag higher over the fixtures of the car when she gets in
__________________


It is not gloss primer .............. it is duct tape silver!
clf is offline   Reply With Quote
Old 18th February 2020, 21:28   #10
DMGRS
Discount MG Rover Spares
 
DMGRS's Avatar
 
MG ZT + ZTT - both CDTi Auto

Join Date: Jun 2011
Location: Hythe, Southampton
Posts: 10,840
Thanks: 452
Thanked 3,046 Times in 1,891 Posts
Default

I've had a couple of instances in my own 75 ownership, the switches can stick (although of course yours is fine - just for anyone else with the same issue).

If anyone has the same issue occurring randomly, I'd take the switch out and clean it thoroughly with switch cleaner, or swap with a good used replacement.
__________________

Visit our Shop - Discount MG Rover Spares
Your trusted MG Rover specialist!
Tel: 02380 001133 / Email: sales@dmgrs.co.uk

Full Metal KV6 Thermostat Kits now stocked! Click Here
UK postage now reduced in price, and free for orders over £300.

Remember - discount code FORUM5 for 5% off
DMGRS is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +1. The time now is 04:25.


Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.
Copyright © 2006-2020, The Rover 75 & MG ZT Owners Club Ltd