Go Back   The 75 and ZT Owners Club Forums > The 75 and ZT Owners Club Forums > I.C.E. Forum > Sat Nav Hardware & Software > Double Din Navigation Systems
Register FAQ Image Gallery Members List Calendar Search Today's Posts Mark Forums Read
Notices

Reply
 
Thread Tools Display Modes
Old 7th June 2019, 13:20   #1
T16
I really should get out more.......
 
ZT CDTi 135, ZT260SE

Join Date: Feb 2011
Location: Dundee
Posts: 2,853
Thanks: 10
Thanked 325 Times in 207 Posts
Default Xtrons

No-one should EVER buy one of these.

Nothing but absolute garbage. Avoid at all costs.

1) Slow
2) Hangs
3) Locks up randomly requiring hard reset.
4) Wifi just drops making it totally useless for downloading maps, ive spent DAYS even trying to download from a laptop IN THE CAR RIGHT NEXT TO IT.
5) when Nav is running unit is so slow volume commands take up to 30 secs to take effect.
6) When volume takes 30secs to work, sometimes it turns it up instead of down meaning I have had to physically pull over and get out until it has recovered.
7) units iant acutually the same dimensions as the BMW original, and if you want it flush like OE you have to modify.
8) Each time I get in the car I have to scan/search for radio stations, it never saves, NEVER.
9) It actually lies to your face, when the Wifi has dropped, it still has the connected icon in the top, pretending all is well, but when tracing things on the laptop, there are no packets from the c-rappy xtrons. So the wifi stack is crashing, its pathetic.
Right now if I had an alternative, I would rip this P.O.S out and smash it to bits with a hammer, its disgusting chinese filth. These pieces of garbage have more bugs than a Bangkok massage parlour.

Last edited by T16; 7th June 2019 at 13:42..
T16 is offline   Reply With Quote
Old 7th June 2019, 18:25   #2
steveo
I really should get out more.......
 
None

Join Date: Sep 2010
Location: N/a
Posts: 2,104
Thanks: 1,372
Thanked 546 Times in 383 Posts
Default TD717G (Xtrons)

Hi
I had a Xtrons Td717g fitted to my 75 for years and never had a problem and when I sold the car the unit was fitted to my daughters Corsa C and is still going through strong .
No Wi-Fi though

Regards
Steve
steveo is offline   Reply With Quote
Old 7th June 2019, 18:38   #3
Russp
Avid contributor
 
MG ZT

Join Date: Dec 2018
Location: holt
Posts: 162
Thanks: 109
Thanked 14 Times in 12 Posts
Default

I've got one and while its had the odd bug it's quite reliable now.
Odd times its locked up on maps but most phones do too
Think you must have a bad one mate
Russp is offline   Reply With Quote
Old 7th June 2019, 18:59   #4
T16
I really should get out more.......
 
ZT CDTi 135, ZT260SE

Join Date: Feb 2011
Location: Dundee
Posts: 2,853
Thanks: 10
Thanked 325 Times in 207 Posts
Default

The firmware I have is:-

MTCD_HH_V2.30

Not sure if that means the unit is rubbish, or the firmware was ever updated to remove bugs etc...
T16 is offline   Reply With Quote
Old 8th June 2019, 01:10   #5
clf
This is my second home
 
clf's Avatar
 
MG ZT CDTi

Join Date: Jan 2014
Location: carrick
Posts: 6,217
Thanks: 2,762
Thanked 1,888 Times in 1,439 Posts
Default

Quote:
Originally Posted by T16 View Post
No-one should EVER buy one of these.

Nothing but absolute garbage. Avoid at all costs.

1) Slow
2) Hangs
3) Locks up randomly requiring hard reset.
4) Wifi just drops making it totally useless for downloading maps, ive spent DAYS even trying to download from a laptop IN THE CAR RIGHT NEXT TO IT.
5) when Nav is running unit is so slow volume commands take up to 30 secs to take effect.
6) When volume takes 30secs to work, sometimes it turns it up instead of down meaning I have had to physically pull over and get out until it has recovered.
7) units iant acutually the same dimensions as the BMW original, and if you want it flush like OE you have to modify.
8) Each time I get in the car I have to scan/search for radio stations, it never saves, NEVER.
9) It actually lies to your face, when the Wifi has dropped, it still has the connected icon in the top, pretending all is well, but when tracing things on the laptop, there are no packets from the c-rappy xtrons. So the wifi stack is crashing, its pathetic.
Right now if I had an alternative, I would rip this P.O.S out and smash it to bits with a hammer, its disgusting chinese filth. These pieces of garbage have more bugs than a Bangkok massage parlour.
pay NAUGHTY WORD-NAUGHTY WORD-NAUGHTY WORD-NAUGHTY WORD-NAUGHTY WORD- money, get NAUGHTY WORD-NAUGHTY WORD-NAUGHTY WORD-NAUGHTY WORD-NAUGHTY WORD- product..... if it was in the car, clarify your whinge with that. If you paid for it and expected more, wind yer neck in, even with scottish blood in you, you cannot expect a 200 quid double din stereo to scratch yer balls whilst playing the local tunes.................. maybe you can?

NAUGHTY WORD-NAUGHTY WORD-NAUGHTY WORD-NAUGHTY WORD-NAUGHTY WORD- = sh1te
__________________


It is not gloss primer .............. it is duct tape silver!
clf is online now   Reply With Quote
Old 8th June 2019, 02:56   #6
T16
I really should get out more.......
 
ZT CDTi 135, ZT260SE

Join Date: Feb 2011
Location: Dundee
Posts: 2,853
Thanks: 10
Thanked 325 Times in 207 Posts
Default

Quote:
Originally Posted by clf View Post
pay NAUGHTY WORD-NAUGHTY WORD-NAUGHTY WORD-NAUGHTY WORD-NAUGHTY WORD- money, get NAUGHTY WORD-NAUGHTY WORD-NAUGHTY WORD-NAUGHTY WORD-NAUGHTY WORD- product..... if it was in the car, clarify your whinge with that. If you paid for it and expected more, wind yer neck in, even with scottish blood in you, you cannot expect a 200 quid double din stereo to scratch yer balls whilst playing the local tunes.................. maybe you can?

NAUGHTY WORD-NAUGHTY WORD-NAUGHTY WORD-NAUGHTY WORD-NAUGHTY WORD- = sh1te
And your recommendation for a functioning alternative (android too) is what exactly?

All these "brands" come right out of the same factory in China.
T16 is offline   Reply With Quote
Old 8th June 2019, 05:30   #7
Les4048
I really should get out more.......
 
Les4048's Avatar
 
Rover 75 Tourer/ MG ZT-T 400

Join Date: May 2012
Location: Lhanbryde
Posts: 2,930
Thanks: 2,347
Thanked 1,289 Times in 742 Posts
Default

Well thousands of people are using them Ross with no complaints and the units from trader Jubberbelly receive nothing but praise. Your comment about them all coming from the same factory, is that made out of anger or frustration or do you have proof that this is so.

https://www.androidice.com/
Les4048 is offline   Reply With Quote
The Following 2 Users Say Thank You to Les4048 For This Useful Post:
Old 8th June 2019, 09:37   #8
aircub
Gets stuck in
 
MG-ZT Cdti 131

Join Date: Nov 2006
Location: Poole
Posts: 667
Thanks: 92
Thanked 109 Times in 96 Posts
Default

Quote:
Originally Posted by T16 View Post
The firmware I have is:-

MTCD_HH_V2.30

Not sure if that means the unit is rubbish, or the firmware was ever updated to remove bugs etc...
Can you post pictures from your system/about page that shows the Model/Android version
aircub is offline   Reply With Quote
Old 8th June 2019, 13:16   #9
vitesse
Gets stuck in
 
Rover 75 Saloon Auto Conn

Join Date: Jul 2011
Location: Gšvle, Sweden
Posts: 909
Thanks: 93
Thanked 228 Times in 192 Posts
Default

Donít recognise many of your problems except poor fitting but one thing missing on your list which my Xtrons (Jubbs) suffers from is GPS lag, it takes ages to find satellites unlike my old Win unit. Repositioned aerial, tried another GPS programme, still the same but weirdly, once it finds them itís fine for hours, can go into shops, restart the car and instantly there but next day after a long sleep itís the same procedure again.

Regards
vitesse is offline   Reply With Quote
Old 8th June 2019, 13:26   #10
aircub
Gets stuck in
 
MG-ZT Cdti 131

Join Date: Nov 2006
Location: Poole
Posts: 667
Thanks: 92
Thanked 109 Times in 96 Posts
Default

Quote:
Originally Posted by vitesse View Post
Donít recognise many of your problems except poor fitting but one thing missing on your list which my Xtrons (Jubbs) suffers from is GPS lag, it takes ages to find satellites unlike my old Win unit. Repositioned aerial, tried another GPS programme, still the same but weirdly, once it finds them itís fine for hours, can go into shops, restart the car and instantly there but next day after a long sleep itís the same procedure again.

Regards
Well my Jubbs Android 8.0 unit has been great no problems at all. My GPS is almost instant, at least itís working by the time tomtom has flashed up. Only downside is they never released an update to 8.1 or 9 so stuck with android 8.0
aircub is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +1. The time now is 11:27.


Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Copyright © 2006-2019, The Rover 75 & MG ZT Owners Club Ltd