Go Back   The 75 and ZT Owners Club Forums > The 75 and ZT Owners Club Forums > I.C.E. Forum
Register FAQ Image Gallery Members List Calendar Search Today's Posts Mark Forums Read
Notices

Reply
 
Thread Tools Display Modes
Old 5th June 2019, 11:33   #41
KWIL
Precise
 
Rover 75 Tourer 2.5KV6 Connoisseur SE

Join Date: Mar 2013
Location: Fleet
Posts: 2,157
Thanks: 411
Thanked 394 Times in 316 Posts
Default

9218 is the same unit as I have, BUT it is different to Colin's because his has the SD card slot on the lower left side, these do not have such a slot AND no RDS.

Now on subject of Radio. Android unit works on bench with short wire aerial, original Symphony unit works in car, just checked. Install Android, no radio sound when when connected to car aerial, disconnect car aerial and insert same short piece of wire, sound reappears WHAT IS HAPPENING? or not as the case may be.
KWIL is offline   Reply With Quote
The Following User Says Thank You to KWIL For This Useful Post:
Old 5th June 2019, 13:35   #42
KWIL
Precise
 
Rover 75 Tourer 2.5KV6 Connoisseur SE

Join Date: Mar 2013
Location: Fleet
Posts: 2,157
Thanks: 411
Thanked 394 Times in 316 Posts
Default

Problem probably sussed, the aerial amplifier needs closer attention. Watch this space.
KWIL is offline   Reply With Quote
Old 5th June 2019, 15:52   #43
Split or Bust
Regular poster
 
Rover 75 Saloon

Join Date: Mar 2019
Location: Slough
Posts: 76
Thanks: 18
Thanked 42 Times in 18 Posts
Default

Quote:
Originally Posted by KWIL View Post
9218 is the same unit as I have, BUT it is different to Colin's because his has the SD card slot on the lower left side, these do not have such a slot AND no RDS.
Apols, I had read that ages back and forgot when I wrote my post.

Bit of a pain no RDS and no SD card slot but can probably live without those for such a low price.

I've bought one so wil be interesting to see what arrives.
Split or Bust is offline   Reply With Quote
Old 6th June 2019, 16:06   #44
KWIL
Precise
 
Rover 75 Tourer 2.5KV6 Connoisseur SE

Join Date: Mar 2013
Location: Fleet
Posts: 2,157
Thanks: 411
Thanked 394 Times in 316 Posts
Default

Well I am there at last, connection to power up aerial amplifier now made and stations galore. Now to learn all the touch screen controls and road test it all.

No pics I am afraid as I do not use any of the photo apps. Can email to any interested party though.
KWIL is offline   Reply With Quote
Old 6th June 2019, 17:31   #45
Dallas
This is my second home
 
Dallas's Avatar
 
MG ZT190+ 2001(Y). 2002 MG TF 135. 2016 Dacia Sandero Stepway Laureate 0.9TCe Turbo SUV Crossover

Join Date: Jun 2009
Location: Dorset
Posts: 7,673
Thanks: 2,936
Thanked 2,741 Times in 1,876 Posts
Default

Quote:
Originally Posted by KWIL View Post
Well I am there at last, connection to power up aerial amplifier now made and stations galore. Now to learn all the touch screen controls and road test it all.
That is good news...
__________________

MG ZT 190+ V6 - MG TF 135 1.8
Born 4th July 2001 17:24:11 - Born 8th January 2002 09:02:26.
Comms no: 409 - Comms no: ---
53rd Solar Red ZT (code: CEU) to be made out of 1,888 Solar Red ZT's - 38th MG TF in BRG Pearlescent (code: HFF) to be made out of 3,353 BRG Pearlescent TF's.
193rd ZT190+ to be made out of 4,023 - 123rd MGTF 135 to be made out of 19,475.
200th ZT to be assembled out of 18,894 - 145th MG TF to be assembled out of 41,656.
Made in the UK by MG Rover Group Ltd
Dallas is offline   Reply With Quote
The Following User Says Thank You to Dallas For This Useful Post:
Old 12th June 2019, 17:54   #46
Split or Bust
Regular poster
 
Rover 75 Saloon

Join Date: Mar 2019
Location: Slough
Posts: 76
Thanks: 18
Thanked 42 Times in 18 Posts
Default

The unit arrived today, box and instructions say 9218 and like KWIL’s it has the MIC and RST (reset) buttons in the top left corner and no SD card slot.

I plan to make 2 cut outs in the front of the fascia panel to slot in the 2 USB ports, to neaten it up and for easy access. Many thanks to Mike Trident who gave me the idea the other day in his post (#10382) with his 3.5mm audio socket

What I did with my Rover 75/MG ZT today - see post 10382

I’ve got the Ł14 Dynamic Sounds fascia trim, as mentioned by jpdoc in post #17, as opposed to the dearer & slightly larger opening MG7 fascia trim so will be attacking it with the Stanley knife soon

CT23RO01-Black-Double-Din-CD-Stereo-Fascia-Trim-For-Rover-75

GPS lead is 70” / 178cm long and I’m conscious of Colin’s comment on it being a bit short, makes you wonder why they didn’t round it up to 2m.

As for ISO leads etc, just need to work out what ones Willy currently has and see if I need any new ones.

Colin NI have you fitted the rear camera yet? Be great to know how you got on especially on placement & how you wired up for reverse.

Thanks to all for the helpful instructions, suggestions etc. Going to be the weekend at the earliest before I even start to look at installing so watch this space.
Attached Images
File Type: jpg IMG_8017.JPG (116.4 KB, 22 views)
File Type: jpg IMG_8018.JPG (94.2 KB, 19 views)
File Type: jpg IMG_8020.jpg (89.1 KB, 20 views)
Split or Bust is offline   Reply With Quote
Old 12th June 2019, 18:33   #47
Colin_NI
NI/ROI Regional Secretary
 
Colin_NI's Avatar
 
ZT-T 190+ / 75 Tourer Club CDT Auto

Join Date: May 2009
Location: Antrim
Posts: 7,605
Thanks: 138
Thanked 694 Times in 409 Posts
Default

Not yet. All plans are on hold as not has ran out and its need a bit of sill work done, and I'm not having a bodge job done so it's off to body shop for paint work also.
Colin_NI is offline   Reply With Quote
Old 15th June 2019, 22:04   #48
Split or Bust
Regular poster
 
Rover 75 Saloon

Join Date: Mar 2019
Location: Slough
Posts: 76
Thanks: 18
Thanked 42 Times in 18 Posts
Default Pain in the.....

Rain put paid to some work in the garden so thought I'd get started on putting the new unit in Willy.

Slowly does it and out comes the Sony single din bluetooth unit. Looks at the connectors and at first sight they look the same, but in fact they are almost mirror images…aaarrrggghhh.

So looks like I’ll be cutting off the existing (Sony) connector and then use connector blocks to pair with the new unit connector. That probably explains why the new connector has open wires at the other end….

Some good news though looks like I may have a Connects2 steering wheel stalks control unit though can’t be sure which one it is as I can’t match the numbers/codes on the back of it to Connects2 website. I’ve dropped them an email to see what advice they can give.

And there I was thinking this was going to be a relatively simple instal….how wrong was I…hey ho...
Attached Images
File Type: jpg 1 - back of Connects2.jpg (131.7 KB, 22 views)
File Type: jpg 2 - all connectors to Sony.jpg (131.9 KB, 22 views)
File Type: jpg 3 - back of chinese 2 din unit.jpg (127.4 KB, 25 views)
File Type: jpg 4 - ISO connectors.jpg (18.6 KB, 21 views)
File Type: jpg 5 - Connects2 to lead 486.jpg (136.9 KB, 20 views)
File Type: jpg 6 - lead 486.jpg (118.1 KB, 20 views)
File Type: jpg 7 - Rover to lead 486.jpg (115.7 KB, 21 views)
Split or Bust is offline   Reply With Quote
Old 20th June 2019, 15:15   #49
KWIL
Precise
 
Rover 75 Tourer 2.5KV6 Connoisseur SE

Join Date: Mar 2013
Location: Fleet
Posts: 2,157
Thanks: 411
Thanked 394 Times in 316 Posts
Default

1.7M GPS aerial lead is Not a problem.

Just returned from 800 mile round trip without problems. I placed the black unit in the centre of the dash close as possible to glass and routed the lead around base of screen to the passenger side at base of A pillar, removed A pillar cover and then routed cable inside dash as far as the centre console.

Only comment so far, screen brightness leaves a lot to be desired, light reflects from sandstone seating!
KWIL is offline   Reply With Quote
Old 20th June 2019, 15:18   #50
KWIL
Precise
 
Rover 75 Tourer 2.5KV6 Connoisseur SE

Join Date: Mar 2013
Location: Fleet
Posts: 2,157
Thanks: 411
Thanked 394 Times in 316 Posts
Default

Split or Bust,

If your only connector problem is the pin locations, you can pop them out of the covers and reinsert.
KWIL is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +1. The time now is 05:58.


Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Copyright © 2006-2019, The Rover 75 & MG ZT Owners Club Ltd