Go Back   The 75 and ZT Owners Club Forums > The 75 and ZT Owners Club Forums > The 75 and ZT Owners Club General Forum
Register FAQ Image Gallery Members List Calendar Search Today's Posts Mark Forums Read
Notices

Reply
 
Thread Tools Display Modes
Old 19th June 2019, 18:29   #1
Craigc
Regular poster
 
75 saloon

Join Date: Oct 2017
Location: Ayrshire
Posts: 32
Thanks: 0
Thanked 1 Time in 1 Post
Question Parking sensor issue

Good evening I have read through all threads with issues with parking sensors, I have the dreaded long beep when out into reverse and then nothing.

All sensors are ticking when I put ear to them, reverse lights are on and working no sign of corrosion on connectors fine so what else could it be?
Craigc is offline   Reply With Quote
Old 19th June 2019, 20:11   #2
trikey
Premium Trader
 
trikey's Avatar
 
T4

Join Date: Nov 2010
Location: Norfolk
Posts: 24,878
Thanks: 5,481
Thanked 8,626 Times in 5,173 Posts
Default

Could be a break in the loom somewhere.
__________________
Lest we forget..
trikey is offline   Reply With Quote
Old 19th June 2019, 20:41   #3
m2n
Gets stuck in
 
m2n's Avatar
 
Rover 75 2004 Contemporary SE 2.5 Auto

Join Date: Feb 2018
Location: Preston
Posts: 513
Thanks: 67
Thanked 56 Times in 46 Posts
Default

Mine is the opposite, think I got a short somewhere as I get a constant tone, but then can go days with it working ok....
__________________
To have and not need, than need and not have.
Eve was born on: Tuesday 14th September 2004 @ 07.54.23
Date of first Registration: Friday 24th September 2004
She was the: 103,715th 75 to run off production line, out of 112,381
She was the: 382nd 75 2.5 V6 Contemporary SE to be made out of 686
She was the: 1,415th 75 in Firefrost Red (code CEV) to be made out of 2,089 Firefrost Red 75's
m2n is offline   Reply With Quote
Old 19th June 2019, 20:49   #4
Craigc
Regular poster
 
75 saloon

Join Date: Oct 2017
Location: Ayrshire
Posts: 32
Thanks: 0
Thanked 1 Time in 1 Post
Default

Great thanks will do a continuity and resistance on each wire from parking Ecu to each sensor, any advise on the other side from parking ecu loom from boot to engine side where to take readings from?
Craigc is offline   Reply With Quote
Old 19th June 2019, 20:49   #5
Mike Noc
Relax, it's a Rover.
 
Mike Noc's Avatar
 
Rover 75 CDT Manual Connoisseur SE, Rover 75 CDT Automatic Connoisseur SE & a Freelander Td4.

Join Date: Jul 2009
Location: Hampshire
Posts: 9,718
Thanks: 1,803
Thanked 2,229 Times in 1,676 Posts
Default

Quote:
Originally Posted by m2n View Post
Mine is the opposite, think I got a short somewhere as I get a constant tone, but then can go days with it working ok....



Check the surfaces of the sensors. Any corrosion or muck on them and you will get a constant beep.

Had it on mine and after rubbing down and repainting the sensors all was well.












.

Last edited by Mike Noc; 19th June 2019 at 21:09..
Mike Noc is online now   Reply With Quote
Old 19th June 2019, 22:28   #6
trikey
Premium Trader
 
trikey's Avatar
 
T4

Join Date: Nov 2010
Location: Norfolk
Posts: 24,878
Thanks: 5,481
Thanked 8,626 Times in 5,173 Posts
Default

Quote:
Originally Posted by Craigc View Post
Great thanks will do a continuity and resistance on each wire from parking Ecu to each sensor, any advise on the other side from parking ecu loom from boot to engine side where to take readings from?


Concentrate on the loom behind the bumper, Iíve never had an issue from the ecu to the front of the car.
__________________
Lest we forget..
trikey is offline   Reply With Quote
Old 19th June 2019, 22:37   #7
Craigc
Regular poster
 
75 saloon

Join Date: Oct 2017
Location: Ayrshire
Posts: 32
Thanks: 0
Thanked 1 Time in 1 Post
Default

Thanks for the advise will have another go tomorrow
Craigc is offline   Reply With Quote
Old 20th June 2019, 06:31   #8
smudge.g
Loves to post
 
smudge.g's Avatar
 
75 Tourer CDTi Connie SE

Join Date: Jun 2017
Location: Keith, Banffshire
Posts: 420
Thanks: 304
Thanked 84 Times in 64 Posts
Default

If you need a replacement rear loom, i have a spare taken from a Tourer I believe, that i bought for my car but the one from my recent donor vehicle was in slightly better condition. Can post to you for just cost of postage if it helps you!
__________________
My 75 Tourer CDTi was born Saturday, 21st June 2003 @ 09:50

My 75 was the 18,749th 75 Tourer to run off the production line, out of 27,407
It was the 195th 75 Tourer CDT Connoisseur SE (135) to be made out of 2,074
and the 1,789th 75 Tourer in Wedgewood Blue Metallic (code: JEL) to be made out of 1,871 Wedgewood Blue Metallic 75 Tourers
smudge.g is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +1. The time now is 14:57.


Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Copyright © 2006-2019, The Rover 75 & MG ZT Owners Club Ltd