Go Back   The 75 and ZT Owners Club Forums > The 75 and ZT Owners Club Forums > Technical Help Forum
Register FAQ Image Gallery Members List Calendar Search Today's Posts Mark Forums Read
Notices

Reply
 
Thread Tools Display Modes
Old 22nd May 2022, 20:55   #1
macafee2
This is my second home
 
Rover 75 Saloon & Tourer

Join Date: Sep 2012
Location: Lincoln
Posts: 13,550
Thanks: 1,601
Thanked 2,971 Times in 2,126 Posts
Default Air con and demist test

My Air con is not working and so I am looking for advice.

I have turned my engine on, turned on the air con and pressed the demist windscreen button. The fan just behind the bumper is not running. Is this my problem? I can see the grey resistor but at the moment cannot tell if it is in one piece.
The system was regassed perhaps 2 or even 3 years ago and is regularly used.

Anything else I should check or just go for a gold resistor replacement?

thank you

macafee2

just found this thread but will take any advice you can offer
https://www.the75andztclub.co.uk/for...ht=testing+fan

Last edited by macafee2; 22nd May 2022 at 21:00..
macafee2 is offline   Reply With Quote
Old 22nd May 2022, 21:04   #2
stevestrat
This is my second home
 
ZT260 #243 (resting)

Join Date: May 2010
Location: Prestonpans
Posts: 21,117
Thanks: 624
Thanked 4,493 Times in 3,269 Posts
Default

Its aircon off and press the demist button.
__________________
Steve


T4 Location Map
stevestrat is offline   Reply With Quote
The Following User Says Thank You to stevestrat For This Useful Post:
Old 22nd May 2022, 21:08   #3
macafee2
This is my second home
 
Rover 75 Saloon & Tourer

Join Date: Sep 2012
Location: Lincoln
Posts: 13,550
Thanks: 1,601
Thanked 2,971 Times in 2,126 Posts
Default

Quote:
Originally Posted by stevestrat View Post
Its aircon off and press the demist button.
right I'll go do another test, just to check, is that econ button off or the whole thing off?

macafee2
macafee2 is offline   Reply With Quote
Old 22nd May 2022, 21:11   #4
bl52krz
This is my second home
 
bl52krz's Avatar
 
Rover 75 cdt club + Rover 2.5 KV6 Conni SE

Join Date: May 2008
Location: Birmingham
Posts: 10,621
Thanks: 6,431
Thanked 2,204 Times in 1,692 Posts
Default

Air con off. Turn ignition on and just press the demist button.
__________________
Great Barr, Birmingham.
bl52krz is offline   Reply With Quote
Old 22nd May 2022, 21:12   #5
macafee2
This is my second home
 
Rover 75 Saloon & Tourer

Join Date: Sep 2012
Location: Lincoln
Posts: 13,550
Thanks: 1,601
Thanked 2,971 Times in 2,126 Posts
Default

Quote:
Originally Posted by stevestrat View Post
Its aircon off and press the demist button.
thank you for the quick reply, ok did another test, engine running, air con off, pressed windscreen demist button and fan still not running. Resistor?

macafee2
macafee2 is offline   Reply With Quote
Old 22nd May 2022, 21:15   #6
stevestrat
This is my second home
 
ZT260 #243 (resting)

Join Date: May 2010
Location: Prestonpans
Posts: 21,117
Thanks: 624
Thanked 4,493 Times in 3,269 Posts
Default

Quote:
Originally Posted by macafee2 View Post
right I'll go do another test, just to check, is that econ button off or the whole thing off?

macafee2
Econ kills the aircon and reverts to "normal" ventilation. After pressing demist the rad fan should run continuously at low speed. If there's a problem the fan will pulse on/off at a high speed, on for several seconds, off for several seconds.

Whether you need the engine running depends on which model, needed it running with the 1.8T I had.
__________________
Steve


T4 Location Map
stevestrat is offline   Reply With Quote
Old 22nd May 2022, 21:43   #7
macafee2
This is my second home
 
Rover 75 Saloon & Tourer

Join Date: Sep 2012
Location: Lincoln
Posts: 13,550
Thanks: 1,601
Thanked 2,971 Times in 2,126 Posts
Default

Quote:
Originally Posted by stevestrat View Post
Econ kills the aircon and reverts to "normal" ventilation. After pressing demist the rad fan should run continuously at low speed. If there's a problem the fan will pulse on/off at a high speed, on for several seconds, off for several seconds.

Whether you need the engine running depends on which model, needed it running with the 1.8T I had.
Diesel CDTI
Of course Econ makes it work as normal, why did I think otherwise even in my moment of non clarity I should have remembered that. Idiot that I am. Thank you for reminding me

macafee2
macafee2 is offline   Reply With Quote
Old 23rd May 2022, 08:18   #8
SD1too
Doesn't do things by halves
 
SD1too's Avatar
 
Rover 75 2.5 Connoisseur Auto (1999) Dealer launch model.

Join Date: Mar 2007
Location: Former Middlesex
Posts: 19,166
Thanks: 1,543
Thanked 3,713 Times in 3,150 Posts
Default You don't need to press "Off"

Quote:
Originally Posted by stevestrat View Post
Its aircon off and press the demist button.
Quote:
Originally Posted by bl52krz View Post
Air con off. Turn ignition on and just press the demist button.
I know that this has been repeated many times on the forum but, for the record, it makes no difference whether or not the "Off" button is pressed.
The windscreen demist mode activates the air conditioning, and therefore the radiator/condenser fan, whatever mode the system was in beforehand: Auto, Econ or Off.

Simon
__________________
"Whatever is rightly done, however humble, is noble."
Sir Henry Royce.
SD1too is offline   Reply With Quote
Old 23rd May 2022, 08:20   #9
SD1too
Doesn't do things by halves
 
SD1too's Avatar
 
Rover 75 2.5 Connoisseur Auto (1999) Dealer launch model.

Join Date: Mar 2007
Location: Former Middlesex
Posts: 19,166
Thanks: 1,543
Thanked 3,713 Times in 3,150 Posts
Default

Quote:
Originally Posted by macafee2 View Post
... ok did another test, engine running, air con off, pressed windscreen demist button and fan still not running. Resistor?
Very likely Ian, yes.

Simon
__________________
"Whatever is rightly done, however humble, is noble."
Sir Henry Royce.
SD1too is offline   Reply With Quote
The Following User Says Thank You to SD1too For This Useful Post:
Old 23rd May 2022, 08:51   #10
MSS
This is my second home
 
Rover 75 CDT, Jaguar XF-S 3.0 V6, V'xhall Omega 2.5 V6 Auto Estate, Twintop 1.8 VVT and Corsa 1.2

Join Date: Dec 2007
Location: Suffolk
Posts: 6,801
Thanks: 258
Thanked 552 Times in 385 Posts
Default

Quote:
Originally Posted by macafee2 View Post
......... Resistor?

macafee2

If the resistor is faulty, it's important to get one of good quality.

See https://www.the75andztclub.co.uk/for...d.php?t=315545
__________________
Member of the Peasant Underdog Class, Grade 1
MSS is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +1. The time now is 19:17.


Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2022, Jelsoft Enterprises Ltd.
Copyright © 2006-2022, The Rover 75 & MG ZT Owners Club Ltd