Go Back   The 75 and ZT Owners Club Forums > The 75 and ZT Owners Club Forums > The 75 and ZT Owners Club General Forum
Register FAQ Image Gallery Members List Calendar Mark Forums Read
Notices

 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
Old 16th November 2023, 10:45   #1
AkpoTek59
Newbie
 
V999 OGA

Join Date: Sep 2021
Location: Middlesbrough
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Default POSSIBLE STARTING ISSUE WITH UNDER BONNET FUEL PUMP MGZTT 2.0 CDTi (Automatic)

Wanted to ask if any of you know the signs of a failing under bonnet fuel pump (UBP)? Or under bonnet fuel pump or starter motor? Sound from in tank pump indicates that is working well, so on the odd occasion I've noticed starting issues even after a decent length drive so am a bit concerned and want to sort it before it gets worse?

My cars a ZTT Automatic diesel 04 model but very well cared for and when the issue comes up I've had to floor throttle before attempting to start otherwise it just won't turn over? Silent or very quiet click till throttle pedal floored then revs up. Hope I don't flood engine when having to do that to start? Jeez

Last edited by AkpoTek59; 16th November 2023 at 10:48..
AkpoTek59 is offline   Reply With Quote
 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 16:36.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2024, vBulletin Solutions Inc.
Copyright © 2006-2023, The Rover 75 & MG ZT Owners Club Ltd