Go Back   The 75 and ZT Owners Club Forums > The 75 and ZT Owners Club Forums > I.C.E. Forum
Register FAQ Image Gallery Members List Calendar Mark Forums Read
Notices

Reply
 
Thread Tools Display Modes
Old 11th November 2023, 17:00   #11
Stu C
Loves to post
 
MG ZT 260

Join Date: Nov 2006
Location: Telford, Shropshire
Posts: 466
Thanks: 4
Thanked 12 Times in 7 Posts
Default

I'm posting again on this as totally baffled now. After all this time there is still no steering wheel controls working, and today plucked up the courage to take the steering wheel off and change the rotary coupler and the actual controls as well. Tried a friends double din radio and separate audio control adapter which work in his car and still nothing.

I just don't know why since the battery was disconnected first time round with everything working it's not now, even with a totally separate working radio set up it doesn't in my car

Any secret reset procedures/fuses/etc... that I could try?
__________________
2004 MG ZT 260 SE #269
2001 MGF 1.8 Steptronic
2019 Seat Ateca Xcellece
Gone but not forgotton - MG ZT 260 SE #171
Member #126
Stu C is offline   Reply With Quote
Old 12th November 2023, 07:13   #12
Roverlike
Avid contributor
 
Roverlike's Avatar
 
Rover, few of them

Join Date: Aug 2011
Location: Split, Croatia
Posts: 235
Thanks: 254
Thanked 117 Times in 82 Posts
Default

I would check that you have continuity on the 2 wires from steering wheel controls connector to the adapter unit. You can do that by using multimeter.
Roverlike is offline   Reply With Quote
Old 15th November 2023, 23:06   #13
VVC-Geeza
This is my second home
 
VVC-Geeza's Avatar
 
2005 Connoisseur SE 1.8 Turbo,2004 45 1.8 Connoisseur and my beloved 1998 VVC Coupe.

Join Date: Nov 2009
Location: Derby.
Posts: 8,791
Thanks: 2,022
Thanked 1,016 Times in 739 Posts
Default

Have a look in settings to see if SRC is configured.My Xtrons unit recently had a new motherboard fitted and I had to input a four digit code followed by programming each SRC function separately.

See #8 on my Xtrons service agents thread just below this one.
__________________

VVC-Geeza is offline   Reply With Quote
Old 19th November 2023, 16:45   #14
xsport
Posted a thing or two
 
rover 75 club se

Join Date: Apr 2011
Location: Leicester
Posts: 1,738
Thanks: 358
Thanked 419 Times in 310 Posts
Default

What radio system was fitted originally in this car ... Are you on infa red switch control system ?
xsport is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 22:11.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2024, vBulletin Solutions Inc.
Copyright © 2006-2023, The Rover 75 & MG ZT Owners Club Ltd