Go Back   The 75 and ZT Owners Club Forums > The 75 and ZT Owners Club Forums > The 75 and ZT Owners Club General Forum
Register FAQ Image Gallery Members List Calendar Search Today's Posts Mark Forums Read
Notices

Reply
 
Thread Tools Display Modes
Old 28th April 2020, 19:18   #1
mgj11
Regular poster
 
mgj11's Avatar
 
MG ZT

Join Date: Nov 2019
Location: Thetford
Posts: 35
Thanks: 8
Thanked 3 Times in 2 Posts
Unhappy Retro fit v6 cruise control frustration

Dear All
I've just fitted cruises control on my 190+ v6. The master switch lights up but the cruise will not engage when the steering wheel controls are used. I have changed the brake pedal switch for a new one from Rimmer Bros and have a clutch pedal switch. All of the wiring was already in place. any help would be greatly appreciated.
mgj11 is offline   Reply With Quote
Old 28th April 2020, 19:20   #2
marinabrian
 
marinabrian's Avatar
 
MG ZT

Join Date: Jan 2011
Location: Newcastle Upon Tyne
Posts: 20,153
Thanks: 3,555
Thanked 10,827 Times in 5,717 Posts
Default

Quote:
Originally Posted by mgj11 View Post
Dear All
I've just fitted cruises control on my 190+ v6. The master switch lights up but the cruise will not engage when the steering wheel controls are used. I have changed the brake pedal switch for a new one from Rimmer Bros and have a clutch pedal switch. All of the wiring was already in place. any help would be greatly appreciated.
Did you fit the vacuum pump, and the throttle body actuator Marcus, just you don't mention them?

Brian
marinabrian is offline   Reply With Quote
Old 28th April 2020, 19:56   #3
trikey
Premium Trader
 
trikey's Avatar
 
75 & ZTT

Join Date: Nov 2010
Location: Norfolk
Posts: 32,308
Thanks: 8,698
Thanked 14,500 Times in 7,908 Posts
Default

If you don't get it sorted easily, you can pop over when the restrictions are lifted and ill have a look for you.
__________________
Lest we forget..
trikey is offline   Reply With Quote
The Following User Says Thank You to trikey For This Useful Post:
Old 28th April 2020, 20:10   #4
mgj11
Regular poster
 
mgj11's Avatar
 
MG ZT

Join Date: Nov 2019
Location: Thetford
Posts: 35
Thanks: 8
Thanked 3 Times in 2 Posts
Default

Have fitted Vacuum pump and actuator
mgj11 is offline   Reply With Quote
Old 28th April 2020, 20:10   #5
mgj11
Regular poster
 
mgj11's Avatar
 
MG ZT

Join Date: Nov 2019
Location: Thetford
Posts: 35
Thanks: 8
Thanked 3 Times in 2 Posts
Default

Thanks Trikey

Last edited by mgj11; 28th April 2020 at 20:14..
mgj11 is offline   Reply With Quote
Old 28th April 2020, 23:04   #6
itcaptainslow
Avid contributor
 
Launch 75 Connoisseur V6

Join Date: Jul 2015
Location: Letchworth
Posts: 135
Thanks: 35
Thanked 51 Times in 32 Posts
Default

Try lifting the brake & clutch pedals in turn with your foot when engaging the cruise control system-simple things first!
itcaptainslow is offline   Reply With Quote
Old 30th April 2020, 14:26   #7
mgj11
Regular poster
 
mgj11's Avatar
 
MG ZT

Join Date: Nov 2019
Location: Thetford
Posts: 35
Thanks: 8
Thanked 3 Times in 2 Posts
Default

Have already tried that thanks
mgj11 is offline   Reply With Quote
Old 30th April 2020, 16:23   #8
genpk
Posted a thing or two
 
Rover 75 Saloon MGZT

Join Date: Jul 2012
Location: Perth, AUSTRALIA
Posts: 1,650
Thanks: 3
Thanked 450 Times in 294 Posts
Default

Could be somthing else but i vaguely remember somthing about a certain type of horn being required to be fitted for it to work. The plug for it was near the ecu area i think.
genpk is offline   Reply With Quote
Old 30th April 2020, 18:14   #9
Greeners
Moderator
 
Greeners's Avatar
 
MG-ZTT

Join Date: Mar 2007
Location: Ware, Herts
Posts: 19,796
Thanks: 161
Thanked 1,246 Times in 1,035 Posts
Default

Quote:
Originally Posted by genpk View Post
Could be somthing else but i vaguely remember somthing about a certain type of horn being required to be fitted for it to work. The plug for it was near the ecu area i think.

That's when you add Powerwash
Greeners is offline   Reply With Quote
Old 1st May 2020, 12:05   #10
genpk
Posted a thing or two
 
Rover 75 Saloon MGZT

Join Date: Jul 2012
Location: Perth, AUSTRALIA
Posts: 1,650
Thanks: 3
Thanked 450 Times in 294 Posts
Default

Quote:
Originally Posted by Greeners View Post
That's when you add Powerwash
ah, thats right, i remember now, i put a zt front on one of my 75s and was trying to fit the extra washers for the headlights.
Between brian and trikey, they will know exactly what is required to make cruise control work!!

Last edited by genpk; 1st May 2020 at 12:09..
genpk is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +1. The time now is 13:23.


Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2022, Jelsoft Enterprises Ltd.
Copyright © 2006-2022, The Rover 75 & MG ZT Owners Club Ltd