Go Back   The 75 and ZT Owners Club Forums > The 75 and ZT Owners Club Forums > Technical Help Forum
Register FAQ Image Gallery Members List Calendar Search Today's Posts Mark Forums Read
Notices

Reply
 
Thread Tools Display Modes
Old 1st May 2020, 11:34   #1
mgj11
Regular poster
 
mgj11's Avatar
 
MG ZT

Join Date: Nov 2019
Location: Thetford
Posts: 35
Thanks: 8
Thanked 3 Times in 2 Posts
Default Air bag light

I have the dreaded/common problem of the air bag fault. The light will come on the message centre but not on the light just below.
I have changed the plugs in the seats but the problem persists. I removed the instrument cluster to see if a previous owner had taped over the led, but I found that the LEC for the airbag looked "blown" could this be causing the airbag fault making it an open circuit or something?
mgj11 is offline   Reply With Quote
Old 1st May 2020, 12:29   #2
marinabrian
 
marinabrian's Avatar
 
MG ZT

Join Date: Jan 2011
Location: Newcastle Upon Tyne
Posts: 20,153
Thanks: 3,555
Thanked 10,827 Times in 5,717 Posts
Default

Quote:
Originally Posted by mgj11 View Post
I have the dreaded/common problem of the air bag fault. The light will come on the message centre but not on the light just below.
I have changed the plugs in the seats but the problem persists. I removed the instrument cluster to see if a previous owner had taped over the led, but I found that the LEC for the airbag looked "blown" could this be causing the airbag fault making it an open circuit or something?
Nah, it's more than likely been doctored in some fashion, I've never seen a faulty LED on any IPK ever

You can count yourself lucky the display hasn't been ripped off as I found on a members car last year

You would be better to get your car on T4, apart from anything else you can find out what is causing your cruise not to work too

Brian
marinabrian is offline   Reply With Quote
Old 1st May 2020, 14:59   #3
mgj11
Regular poster
 
mgj11's Avatar
 
MG ZT

Join Date: Nov 2019
Location: Thetford
Posts: 35
Thanks: 8
Thanked 3 Times in 2 Posts
Default

I think it will be a trip to T4 after shutdown. Thanks
mgj11 is offline   Reply With Quote
Old 1st May 2020, 15:05   #4
marinabrian
 
marinabrian's Avatar
 
MG ZT

Join Date: Jan 2011
Location: Newcastle Upon Tyne
Posts: 20,153
Thanks: 3,555
Thanked 10,827 Times in 5,717 Posts
Default

Quote:
Originally Posted by mgj11 View Post
I think it will be a trip to T4 after shutdown. Thanks
Trikey will be the closest to you I'd say.......definitely takes the guesswork out of the job

Brian
marinabrian is offline   Reply With Quote
The Following User Says Thank You to marinabrian For This Useful Post:
Old 2nd May 2020, 00:52   #5
trikey
Premium Trader
 
trikey's Avatar
 
75 & ZTT

Join Date: Nov 2010
Location: Norfolk
Posts: 32,308
Thanks: 8,698
Thanked 14,501 Times in 7,908 Posts
Default

Yep only an hour away at a steady speed
__________________
Lest we forget..
trikey is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +1. The time now is 14:03.


Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2022, Jelsoft Enterprises Ltd.
Copyright © 2006-2022, The Rover 75 & MG ZT Owners Club Ltd