Go Back   The 75 and ZT Owners Club Forums > The 75 and ZT Owners Club Forums > Technical Help Forum
Register FAQ Image Gallery Members List Calendar Search Today's Posts Mark Forums Read
Notices

Reply
 
Thread Tools Display Modes
Old 11th November 2020, 08:15   #1
mgj11
Regular poster
 
mgj11's Avatar
 
MG ZT

Join Date: Nov 2019
Location: Thetford
Posts: 35
Thanks: 8
Thanked 3 Times in 2 Posts
Default Steering column controls issues

I had problems this morning with all the controls on the steering column, the indicators didn't work, the wipers didn't work, the radio controls and cruise set also didn't work.
After about 1/2 hour driving the cruise control and radio control started working the wipers started working after a couple of minute, but the indicators where very temperamental all the time. Any ideas please.
__________________
So far, retro fitted cruise control, MG7 climate controls, Android head unit, Leather electric seats fitted, 12v socket in chubby, Shark fin with DAB, FM & GPS, auto dimming rear view mirror, power-fold mirrors & Audi style side repeaters .
mgj11 is offline   Reply With Quote
Old 11th November 2020, 08:23   #2
trikey
Premium Trader
 
trikey's Avatar
 
75 & ZTT

Join Date: Nov 2010
Location: Norfolk
Posts: 32,308
Thanks: 8,698
Thanked 14,501 Times in 7,908 Posts
Default

Try changing the clock spring behind the steering wheel.
__________________
Lest we forget..
trikey is offline   Reply With Quote
Old 11th November 2020, 17:58   #3
mgj11
Regular poster
 
mgj11's Avatar
 
MG ZT

Join Date: Nov 2019
Location: Thetford
Posts: 35
Thanks: 8
Thanked 3 Times in 2 Posts
Default

Thanks, are there different type or is it the same for all Rover 75 and MG ZT?
__________________
So far, retro fitted cruise control, MG7 climate controls, Android head unit, Leather electric seats fitted, 12v socket in chubby, Shark fin with DAB, FM & GPS, auto dimming rear view mirror, power-fold mirrors & Audi style side repeaters .
mgj11 is offline   Reply With Quote
Old 11th November 2020, 18:52   #4
trikey
Premium Trader
 
trikey's Avatar
 
75 & ZTT

Join Date: Nov 2010
Location: Norfolk
Posts: 32,308
Thanks: 8,698
Thanked 14,501 Times in 7,908 Posts
Default

Quote:
Originally Posted by mgj11 View Post
Thanks, are there different type or is it the same for all Rover 75 and MG ZT?

Same part for both models.
__________________
Lest we forget..
trikey is offline   Reply With Quote
Old 16th November 2020, 13:39   #5
mgj11
Regular poster
 
mgj11's Avatar
 
MG ZT

Join Date: Nov 2019
Location: Thetford
Posts: 35
Thanks: 8
Thanked 3 Times in 2 Posts
Default

I've changed the clock spring/squib and both indictor and wiper stalks, cleaned all contacts. The volume control and cruise control are working but I still have an intermittent problem will the indicator, is there any way to test the clock spring/squib?
__________________
So far, retro fitted cruise control, MG7 climate controls, Android head unit, Leather electric seats fitted, 12v socket in chubby, Shark fin with DAB, FM & GPS, auto dimming rear view mirror, power-fold mirrors & Audi style side repeaters .
mgj11 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +1. The time now is 14:05.


Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2022, Jelsoft Enterprises Ltd.
Copyright © 2006-2022, The Rover 75 & MG ZT Owners Club Ltd