Go Back   The 75 and ZT Owners Club Forums > The 75 and ZT Owners Club Forums > Technical Help Forum
Register FAQ Image Gallery Members List Calendar Search Today's Posts Mark Forums Read
Notices

Reply
 
Thread Tools Display Modes
Old 3rd May 2022, 13:54   #1
mgj11
Regular poster
 
mgj11's Avatar
 
MG ZT

Join Date: Nov 2019
Location: Thetford
Posts: 35
Thanks: 8
Thanked 3 Times in 2 Posts
Unhappy Sub frame wows

I'm having clutch problems (again). Last time I replaced the clutch and slave without removing the sub frame.
This time I wanted to remove it and give it a bit of a refurb and it very tight to replace the slave if you don't.
The problem is the first 2 nuts I went to remove, the ones holding on the air con pipe just turn. It looks like they go into a cylinder thing rather that a welded nut. Am I missing something, any suggestion would be greatly received.
__________________
So far, retro fitted cruise control, MG7 climate controls, Android head unit, Leather electric seats fitted, 12v socket in chubby, Shark fin with DAB, FM & GPS, auto dimming rear view mirror, power-fold mirrors & Audi style side repeaters .
mgj11 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +1. The time now is 13:41.


Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2022, Jelsoft Enterprises Ltd.
Copyright © 2006-2022, The Rover 75 & MG ZT Owners Club Ltd