Go Back   The 75 and ZT Owners Club Forums > The 75 and ZT Owners Club Forums > Technical Help Forum
Register FAQ Image Gallery Members List Calendar Search Today's Posts Mark Forums Read
Notices

Reply
 
Thread Tools Display Modes
Old 22nd October 2019, 09:31   #1
Heddy
This is my second home
 
Rover 75 Mk2. Diesel. Manual.

Join Date: Feb 2013
Location: Exmouth.
Posts: 5,261
Thanks: 433
Thanked 1,083 Times in 867 Posts
Default Why Should This Happen?

It's the old 'brake lights stuck on' again.
With key in position 1...works fine. With key in position 2 (ignition on) brakes lights stay on after the first press. your thoughts appreciated.
Cheers
Heddy.
__________________
If it isn't a 75 then it's just a car.
Heddy is offline   Reply With Quote
Old 22nd October 2019, 09:48   #2
squire
Mad on moggies
 
squire's Avatar
 
Rover 75 saloon, Connie cdt. MGB GT, 2 Morris Minor Travellers

Join Date: May 2011
Location: Bilston
Posts: 1,139
Thanks: 813
Thanked 286 Times in 225 Posts
Default

It sounds like the brake light switch to me. I had problems with mine for over a year some years ago until I changed it for a proper one from Rimmers, eBay ones don't work, it's a pig of a job and not one I'd be in any hurry to do again.
The how to on here does help a lot.
squire is offline   Reply With Quote
Old 22nd October 2019, 10:02   #3
Heddy
This is my second home
 
Rover 75 Mk2. Diesel. Manual.

Join Date: Feb 2013
Location: Exmouth.
Posts: 5,261
Thanks: 433
Thanked 1,083 Times in 867 Posts
Default

Thanks for responding. I've seen the 'how to', excellent. I just thought that with the lights working fine at switch position 1 would rule out a faulty switch. Will start easy first, fuses.
__________________
If it isn't a 75 then it's just a car.
Heddy is offline   Reply With Quote
Old 22nd October 2019, 14:08   #4
Avulon
This is my second home
 
75/75

Join Date: Oct 2011
Location: Tanelorn
Posts: 4,477
Thanks: 846
Thanked 1,018 Times in 830 Posts
Default

Quote:
Originally Posted by Heddy View Post
Thanks for responding. I've seen the 'how to', excellent. I just thought that with the lights working fine at switch position 1 would rule out a faulty switch. Will start easy first, fuses.

It would seem to rule out a faulty pedal switch/sensor. Have you checked the connectors to the lamp units at the back for corrosion?
__________________
Need a T4 ?: T4 Owners Map thanks to Stevestrat ( use at your own risk)

Where?:
https://en.wikipedia.org/wiki/Tanelorn
Mods/Retrofits:

PCV vortex 'filter'; bluetooth; inline thermostat; reversing sensors; plenum spyhole ; headlamp washers ; Diy mp3 player replacing CD multichanger; FBH with remote; Headlamp washers; black/chrome front grille, rear blind; Xenon projectors
To do:
puddle lights; 2 Din cd/nav to fit; boot release button
Avulon is offline   Reply With Quote
Old 22nd October 2019, 14:26   #5
bigblue75
Not so newbie
 
Rover 75 saloon

Join Date: Oct 2014
Location: Falkirk
Posts: 146
Thanks: 33
Thanked 28 Times in 22 Posts
Default https://the75andztclub.co.uk/forum/showthread.php?t=244034

Worth a read.














To the end.

Last edited by bigblue75; 22nd October 2019 at 14:31.. Reason: Emphasis
bigblue75 is offline   Reply With Quote
Old 22nd October 2019, 14:39   #6
Heddy
This is my second home
 
Rover 75 Mk2. Diesel. Manual.

Join Date: Feb 2013
Location: Exmouth.
Posts: 5,261
Thanks: 433
Thanked 1,083 Times in 867 Posts
Default

Cheers, had a good read. I notice too that I get a 'beep' when trying to lock, even though all doors etc are closed. I have a charger and sat nav feed on a live fuse and that has started to stay live after switch off. More to do.
__________________
If it isn't a 75 then it's just a car.
Heddy is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +1. The time now is 12:35.


Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Copyright © 2006-2019, The Rover 75 & MG ZT Owners Club Ltd