Go Back   The 75 and ZT Owners Club Forums > The 75 and ZT Owners Club Forums > Technical Help Forum
Register FAQ Image Gallery Members List Calendar Search Today's Posts Mark Forums Read
Notices

Reply
 
Thread Tools Display Modes
Old 3rd May 2021, 15:37   #1
Matt70
Regular poster
 
Matt70's Avatar
 
Rover 75 Saloon

Join Date: May 2017
Location: Southend on Sea
Posts: 48
Thanks: 9
Thanked 9 Times in 5 Posts
Default Problem Starting the CAR

Hi Guys,

from several months I've a problem when start my MG Rover 75 2.5 V6 petrol after a while, I need to wait some time ..I tested the battery and alternator is OK !

I don't understand what can be.. also after driving I lessen a strange noise in the engine

Any help? please...!

Matt
Matt70 is offline   Reply With Quote
Old 4th May 2021, 13:37   #2
stocktake
Vis Whiz
 
stocktake's Avatar
 
Rover 75 2.5 auto Saloon

Join Date: Jun 2007
Location: LEEDS
Posts: 19,784
Thanks: 1,475
Thanked 2,452 Times in 1,351 Posts
Default

Bit more information needed Matt.

Does the car turn over but will not fire or does it fail to turn over?

What kind of noise?
From what area of the engine?
Does it increase and decrease with engine speed?
Does the noise continue after you have switched the engine off?

When were the timing belts last changed?
__________________
Dave...



Lost a few stones and a Gall Bladder and part of a bile duct and all of my dignity in the suppository incident
stocktake is offline   Reply With Quote
The Following User Says Thank You to stocktake For This Useful Post:
Old 5th May 2021, 23:02   #3
COLVERT
Foreign correspondent
 
COLVERT's Avatar
 
R75 Saloon.

Join Date: Feb 2009
Location: France/or Devon.
Posts: 12,774
Thanks: 3,444
Thanked 1,825 Times in 1,545 Posts
Default

Matt, where are you ??--Please speak to us so we can try and help you.--
__________________
COLVERT is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +1. The time now is 02:42.


Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2021, Jelsoft Enterprises Ltd.
Copyright © 2006-2020, The Rover 75 & MG ZT Owners Club Ltd