Go Back   The 75 and ZT Owners Club Forums > The 75 and ZT Owners Club Forums > I.C.E. Forum > Sat Nav Hardware & Software > Double Din Navigation Systems
Register FAQ Image Gallery Members List Calendar Mark Forums Read
Notices

Reply
 
Thread Tools Display Modes
Old 11th March 2021, 18:32   #1
lasercutter
Avid contributor
 
Rover 75

Join Date: Feb 2013
Location: Basildon
Posts: 193
Thanks: 1
Thanked 39 Times in 32 Posts
Default Navall 2 android update help needed

Hi all, probably a long shot but I recently recovered my old Navall 2 headset from my sister and was planning on selling it, however the notification bar refuses to work so thought I'd try updating it from android 4.2 to 4.4
Problem is finding the files, so I was hoping someone here might have them or know where to get them, really don't want to sell a faulty unit if it's possible to fix it.


Many thanks
lasercutter is offline   Reply With Quote
Old 11th March 2021, 21:25   #2
mh007
This is my second home
 
mh007's Avatar
 
MG ZT260 SE, MG ZT190+, MG ZTT 160, R75 Conn SE 2.0, R75 Conn SE 2.5 X 3, R75 Club SE 1.8, P5B Coupe

Join Date: Jul 2009
Location: Keynsham, Bristol
Posts: 4,211
Thanks: 65
Thanked 635 Times in 499 Posts
Default

I could be wrong but I have a feeling there were issues running 4.4 on a Navall 2.

I'm sure someone else will be along with more info.
mh007 is offline   Reply With Quote
Old 11th March 2021, 21:33   #3
lasercutter
Avid contributor
 
Rover 75

Join Date: Feb 2013
Location: Basildon
Posts: 193
Thanks: 1
Thanked 39 Times in 32 Posts
Default

searching through the forum it looked like that was the main update people did, if I could re-install the version that's on there I would but factory resetting doesn't work and I'm scratching my head how to fix it
Nothing at the top of the screen works, can't pull down notifications or get to the apps menu
Doing my head in
Attached Images
File Type: jpg 20210311_222834.jpg (128.0 KB, 28 views)
lasercutter is offline   Reply With Quote
Old 13th March 2021, 13:03   #4
mbonwick
Gets stuck in
 
Connoisseur SE 1.8 Auto Saloon

Join Date: Jul 2015
Location: Kendal
Posts: 633
Thanks: 129
Thanked 176 Times in 147 Posts
Default

Are you able to get into the Settings -> About menu?

If we can work out from there what hardware its running, can then probably get one of the community modded ROMs (i.e. updates) that solve a lot of these issues.
mbonwick is offline   Reply With Quote
Old 13th March 2021, 14:06   #5
sewerman
Gets stuck in
 
MG ZT+ CDTi

Join Date: Feb 2014
Location: Wolverhampton
Posts: 633
Thanks: 166
Thanked 264 Times in 154 Posts
Default

Mine started like that then middle of the screen went just about usable now but cant use anything in the centre of the screen 😒

Sent from my SM-G977B using Tapatalk
sewerman is offline   Reply With Quote
Old 14th March 2021, 11:05   #6
lasercutter
Avid contributor
 
Rover 75

Join Date: Feb 2013
Location: Basildon
Posts: 193
Thanks: 1
Thanked 39 Times in 32 Posts
Default

I updated the MCU but it didn't work, it's running MTCB-KGL5-V2.53 and android 4.2.2 (was using MTCB-KGL1-1.72) so I was going to try updating to android 4.4 to see if it fixed the issue, if it didn't then I would assume it's the screen not working at the top 5mm or so.
I saw a link to new screens for about £20 but as I wasn't going to as a lot for the unit I don't know if it's worth the time, effort and expense to try changing it.
If the android update doesn't work I'll probably just bin it
lasercutter is offline   Reply With Quote
Old 14th March 2021, 11:56   #7
sewerman
Gets stuck in
 
MG ZT+ CDTi

Join Date: Feb 2014
Location: Wolverhampton
Posts: 633
Thanks: 166
Thanked 264 Times in 154 Posts
Default

I thought about changing the screen on mine but it looks a bit of a faff. I think someone on here has done it though. If you decide to do it let us know how it goes.

TBH a 6+yr old navall is probaby worthless to most people, although for what i use it for its fine so if i could get a working one I'd be happy .

Testing the one ive been given there's no continuity on the speaker wires so I suspect its a board issue,.

Sent from my SM-G977B using Tapatalk
sewerman is offline   Reply With Quote
Old 14th March 2021, 14:39   #8
mbonwick
Gets stuck in
 
Connoisseur SE 1.8 Auto Saloon

Join Date: Jul 2015
Location: Kendal
Posts: 633
Thanks: 129
Thanked 176 Times in 147 Posts
Default

If it's just the top 5mm of the screen that's not working (notification bar) then I'm pretty sure that was an Android config issue.

May be worth trying one of the community "universal" ROMs like from Malaysk - https://yadi.sk/d/h2_S_Lw9t6O4Qw
mbonwick is offline   Reply With Quote
Old 14th March 2021, 15:24   #9
sewerman
Gets stuck in
 
MG ZT+ CDTi

Join Date: Feb 2014
Location: Wolverhampton
Posts: 633
Thanks: 166
Thanked 264 Times in 154 Posts
Default

If that works keep us posted

Sent from my SM-G977B using Tapatalk
sewerman is offline   Reply With Quote
Old 14th March 2021, 17:56   #10
lasercutter
Avid contributor
 
Rover 75

Join Date: Feb 2013
Location: Basildon
Posts: 193
Thanks: 1
Thanked 39 Times in 32 Posts
Default

well that didn't fix it so I'm going with the screen..ordered one from Ali express for £11 so I'll see if it turns up and works
Hate selling things that don't work properly and even though it probably isn't worth the aggro it will give me something to do
lasercutter is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 19:40.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2024, vBulletin Solutions Inc.
Copyright © 2006-2023, The Rover 75 & MG ZT Owners Club Ltd