Go Back   The 75 and ZT Owners Club Forums > Social Forums > Technology Forum
Register FAQ Image Gallery Members List Calendar Search Today's Posts Mark Forums Read
Notices

Reply
 
Thread Tools Display Modes
Old 31st January 2021, 17:47   #1
Lovel
T4 Geek
 
Lovel's Avatar
 
R40, P6B, L359, Imp, F56, R56, Street Twin

Join Date: Nov 2006
Location: Aberdeenshire
Posts: 2,812
Thanks: 300
Thanked 619 Times in 412 Posts
Question Removing programme shell Win XP

I Inherited an exhaust gas analyser from a local garage who sadly is closing down after about 80 years, and I have been trying to remove the shell created by the analyser software to give me back some form of control with Windows XP, bit like the issue you get with T4 taking your PC over. I was able to get into Bios menu and amended the date due to the software warning calibration out of date and limiting functionality, but ideally I would like to get into Windows Regedit and hopefully remove the software exe which creates the shell. Is Anyone able to advise if there is another way of getting in to allow the edit?
__________________
@@@@@ Genuine NOS Hillman Imp body panels wanted @@@@@@ Almost there just need a Bonnet & Front Headlamp Panel
Lovel is offline   Reply With Quote
Old 2nd February 2021, 19:48   #2
Atlan
Regular poster
 
rover 75

Join Date: May 2016
Location: Home
Posts: 93
Thanks: 4
Thanked 34 Times in 29 Posts
Default

Try here.
https://realtimeissues.wordpress.com...shell-program/
__________________
Illegitimi non carborundum
Atlan is offline   Reply With Quote
Old 2nd February 2021, 20:49   #3
Lovel
T4 Geek
 
Lovel's Avatar
 
R40, P6B, L359, Imp, F56, R56, Street Twin

Join Date: Nov 2006
Location: Aberdeenshire
Posts: 2,812
Thanks: 300
Thanked 619 Times in 412 Posts
Default

Quote:
Originally Posted by Atlan View Post
Thanks for the response but my question is getting the PC into a mode that lets me get DOS to display and then request Reg edit, but this Shell fitted wonít allow me to even get that far.
__________________
@@@@@ Genuine NOS Hillman Imp body panels wanted @@@@@@ Almost there just need a Bonnet & Front Headlamp Panel
Lovel is offline   Reply With Quote
Old 2nd February 2021, 21:39   #4
Atlan
Regular poster
 
rover 75

Join Date: May 2016
Location: Home
Posts: 93
Thanks: 4
Thanked 34 Times in 29 Posts
Default

Close any open programs and restart your computer. ...
Press the "F8" button on your keyboard repeatedly when the first boot menu appears.
Press the down arrow key on your keyboard to select the "Safe Mode with Command Prompt" option.
Press the "Enter" key to boot into DOS mode.
__________________
Illegitimi non carborundum
Atlan is offline   Reply With Quote
The Following User Says Thank You to Atlan For This Useful Post:
Old 4th February 2021, 17:52   #5
Avulon
This is my second home
 
75/75

Join Date: Oct 2011
Location: Tanelorn
Posts: 4,743
Thanks: 921
Thanked 1,116 Times in 890 Posts
Default

You'll need to boot from a different source. for XP you might still have floppy disk drive on it, or the bios may be able to boot from USB. (you'll need an XP bootdisk or bootdisk image, you could even use a linux bootdisk) Doing that will enable you to edit the startup files to set the shell.
__________________
Need a T4 ?: T4 Owners Map thanks to Stevestrat ( use at your own risk)

Where?:
https://en.wikipedia.org/wiki/Tanelorn
Mods/Retrofits:

PCV vortex 'filter'; bluetooth; inline thermostat; reversing sensors; plenum spyhole ; headlamp washers ; Diy mp3 player replacing CD multichanger; FBH with remote; Headlamp washers; black/chrome front grille, rear blind; Xenon projectors
To do:
puddle lights; 2 Din cd/nav to fit; boot release button
Avulon is offline   Reply With Quote
Old 7th February 2021, 01:37   #6
Lovel
T4 Geek
 
Lovel's Avatar
 
R40, P6B, L359, Imp, F56, R56, Street Twin

Join Date: Nov 2006
Location: Aberdeenshire
Posts: 2,812
Thanks: 300
Thanked 619 Times in 412 Posts
Default

I was able to get in via the safe mode command prompt and change the shell to explorer.exe, however upon restart the pc (itís not a normal pc has only a hard drive) all I get is black screen on my monitor, so it seems more complex than just changing the exe file over.

So my next step I am going to try and read the registry via a usb lead from another pc and see if I can change it back to the original shell exe file. Unless anyone has any other ideas to get back into the registry?
__________________
@@@@@ Genuine NOS Hillman Imp body panels wanted @@@@@@ Almost there just need a Bonnet & Front Headlamp Panel
Lovel is offline   Reply With Quote
Old 7th February 2021, 18:20   #7
Atlan
Regular poster
 
rover 75

Join Date: May 2016
Location: Home
Posts: 93
Thanks: 4
Thanked 34 Times in 29 Posts
Default

Are you still able to enter the regedit screen ? Take a look at this page it might give some info re changing the shell.
https://www.winhelponline.com/xp/usershellfolders.htm
__________________
Illegitimi non carborundum
Atlan is offline   Reply With Quote
Old 7th February 2021, 20:32   #8
Lovel
T4 Geek
 
Lovel's Avatar
 
R40, P6B, L359, Imp, F56, R56, Street Twin

Join Date: Nov 2006
Location: Aberdeenshire
Posts: 2,812
Thanks: 300
Thanked 619 Times in 412 Posts
Default

Quote:
Originally Posted by Atlan View Post
Are you still able to enter the regedit screen ? Take a look at this page it might give some info re changing the shell.
https://www.winhelponline.com/xp/usershellfolders.htm
On powering up all I can get is a black screen currently. Perhaps if I try shutting down and F8 on start up it might get me to the safe mode again, will try later.

I took the hard drive out and with an interface was able to access it via another desktop pc which I was able to navigate through it content in the hope I could load the external drive registry, following some online guides I was instructed to navigate to HKEY_LOCAL_MACHINE and then load hive, but Iím not sure which file to search under from these options:
-SAM represents the Sam hive.
-SECURITY represents the Security hive.
-SOFTWARE represents the Software hive.
-SYSTEM represents the System hive
I get to the point where I select Load hive and a dialogue box opens asking for Key nameĒ whatever that is?, do I just type the full destination in this box?
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon\Shell=????.exe.
__________________
@@@@@ Genuine NOS Hillman Imp body panels wanted @@@@@@ Almost there just need a Bonnet & Front Headlamp Panel
Lovel is offline   Reply With Quote
Old 7th February 2021, 22:25   #9
Atlan
Regular poster
 
rover 75

Join Date: May 2016
Location: Home
Posts: 93
Thanks: 4
Thanked 34 Times in 29 Posts
Default

Personally I would try to undo the changes that you have made to the reg, then run MSconfig, Sysedit to see what is loading at startup. From there you might be able to halt the analyser programme from loading. I prefer to keep away from the registry unless I am 100% certain and also have a way to back it up.
__________________
Illegitimi non carborundum
Atlan is offline   Reply With Quote
Old 16th February 2021, 14:15   #10
Lovel
T4 Geek
 
Lovel's Avatar
 
R40, P6B, L359, Imp, F56, R56, Street Twin

Join Date: Nov 2006
Location: Aberdeenshire
Posts: 2,812
Thanks: 300
Thanked 619 Times in 412 Posts
Default

Boy have I spent too much time on this one. Why did I try to change in the 1st place Anyway not much to report still have the same story, no VGA, no white dash, nothing. Have tried resetting bios, disconnected battery, and shorting out a two pin terminal. Still a black screen with no signal. No beeps, no Post, power on self test. Have ended up disconnecting as much as I could, and have the motherboard currently hooked up inside to an old desktop power supply just to establish if I can get something on screen, but nothing so far, have left it on for a few hours.

I cloned the hard drive at least that was successful, and can read it, however I have not been able to apply system restore or amend it.

__________________
@@@@@ Genuine NOS Hillman Imp body panels wanted @@@@@@ Almost there just need a Bonnet & Front Headlamp Panel
Lovel is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +1. The time now is 19:39.


Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2021, Jelsoft Enterprises Ltd.
Copyright © 2006-2020, The Rover 75 & MG ZT Owners Club Ltd